Bug #7283 Test failure: 'update' (using '--ps-protocol': server crash)
Submitted: 14 Dec 2004 17:02 Modified: 14 Jan 2005 19:03
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.3-pre OS:Linux (Linux / Athlon)
Assigned to: Ramil Kalimullin CPU Architecture:Any

[14 Dec 2004 17:02] Joerg Bruehe
Test 'update' fails for me in current 5.0, when I run the test suite with '--ps-protocol'.
In a standard run, this test passes.

This is a non-debug build: 'compile-pentium-max'.

Failure report:
=== cut ===
update                         [ fail ]

Errors are (from /M50/push-5.0/mysql-test/var/log/mysqltest-time) :
/M50/push-5.0/client/.libs/mysqltest: At line 11: unable to execute statement 'update t1 set a=a+10 where a > 34': Lost connection to MySQL server during query (mysql_stmt_errno=2013 returned=1)
(the last lines may be the most important ones)

Ending Tests
Shutting-down MySQL daemon

master not cooperating with mysqladmin, will try manual kill
./mysql-test-run: line 1289: kill: (10) - Kein passender Prozess gefunden
master refused to die. Sending SIGKILL
./mysql-test-run: line 1293: kill: (10) - Kein passender Prozess gefunden
Master shutdown finished
Slave shutdown finished
=== cut ===

I tried to get a backtrace, but may have hit the wrong target:
(gdb) where
#0  0x4022d691 in kill () from /lib/libc.so.6
#1  0x40153511 in pthread_kill () from /lib/libpthread.so.0
#2  0x08295dcb in write_core (sig=32767) at stacktrace.c:220
#3  0x0819ab58 in handle_segfault (sig=32767) at mysqld.cc:1904
#4  0x40156895 in __pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x402df371 in select () from /lib/libc.so.6
#7  0x4114b068 in ?? ()
#8  0x0833f113 in srv_error_monitor_thread (arg=0x0) at srv0srv.c:2018
#9  0x40150c60 in pthread_start_thread () from /lib/libpthread.so.0

Latest changeset on my PC:
ChangeSet@1.1738, 2004-12-14 13:41:32+03:00, gluh@gluh.mysql.r18.ru
  Fix for bug #7223: information_schema: error in "views"

The error is older, as I got it already yesterday but did not yet report.

How to repeat:
Run the test suite with '--ps-protocol'.
[21 Dec 2004 12:47] Ramil Kalimullin
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at

Additional info:

fixed in 5.0.3
[27 Dec 2004 14:09] Joerg Bruehe
I pulled again, re-built, and re-tested: The error is still present (same symptom, no change).

I checked the sources, and the changeset 1.1771 (re-numbered by BK) is included in my sources.
[14 Jan 2005 19:03] Joerg Bruehe
I cannot reproduce it any more, seems to have been corrected (there were corrections for the '--ps-protocol' case).