Bug #72780 mysqlrplcheck also does not detect stopped master or slave server
Submitted: 28 May 2014 11:55 Modified: 29 May 2014 20:52
Reporter: Shahriyar Rzayev (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Utilities Severity:S1 (Critical)
Version:1.4.3 OS:Linux (CentOS 6.5)
Assigned to: CPU Architecture:Any

[28 May 2014 11:55] Shahriyar Rzayev
Description:
Dear all,

mysqlrplcheck also does not show informative error message when master or slave server has stopped:

On master if master mysql stopped:

[root@linuxsrv3 ~]# mysqlrplcheck --master=root:12345@localhost --slave=remote2:Pass@123#@192.168.1.88 -vvv --show-slave-status
# master on localhost: ... ERROR: Cannot connect to the master server.
Error Can't connect to MySQL server on 'localhost:3306' (111 Connection refused)

On slave if slave server stopped:

[root@linuxsrv3 ~]# mysqlrplcheck --master=root:12345@localhost --slave=remote2:Pass@123#@192.168.1.88 -vvv --show-slave-status
# master on localhost: ... connected.
# slave on 192.168.1.88: ... ERROR: Cannot connect to the slave server.
Error Can't connect to MySQL server on '192.168.1.88:3306' (111 Connection refused)

in both conditions we get -> "111 Connection refused".

How to repeat:
See description.

Suggested fix:
Detect if mysql servers stopped or not.
[29 May 2014 7:31] MySQL Verification Team
Hello Shahriyar,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[29 May 2014 20:52] Chuck Bell
Duplicate of BUG#72707.