Bug #72758 mysql connector not working on windows 7 Professional
Submitted: 27 May 2014 6:07 Modified: 27 May 2014 8:55
Reporter: Rommel Sanchez Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.2.6 to 5.3.2 OS:Microsoft Windows (7 Professional SP1)
Assigned to: CPU Architecture:Any

[27 May 2014 6:07] Rommel Sanchez
Description:
I am developing an application that uses mysql odbc connector to connect to mysql server.  Currently I am developing under Windows 7 Ultimate SP1 and I dont have problem under this windows version platform.

However when I tried to install mysql odbc connector 5.2.6, or 5.2.6 or 5.3.2 where msi install or in zip file on Windows 7 Pro SP1, I only get the error "Can't connect to MySQL server on 'x.x.x.x' (10061) when I try to connect the application to the server.

And I noticed that on the ODBC Data source administrator, there is no Version, Company, File and Date information about the Name of the MySQL Driver, it is only blank.  And when I check on the windows registry on the ODBC, the registry does not open or show like its been corrupt.

How to repeat:
Install the mysql connection to Windows 7 Pro SP1

Suggested fix:
I dont know. But I guess you need to fix the code.
[27 May 2014 7:12] Shane Bester
Please make sure you have a MySQL server running and firewall doesn't prevent connections.

http://msdn.microsoft.com/en-us/library/windows/desktop/ms740668(v=vs.85).aspx

WSAECONNREFUSED
10061
[27 May 2014 8:14] Rommel Sanchez
the mysql server is running on the server at ip address x.x.x.x

Now I want to add this information.  The mysql server has two nic: 192.168.1.109 which has the internet connection and 172.29.2.213 which has no internet connection on the lan.

When I connection on 172.29.2.213, I get that 10061 error but if I use the ip at 192.168.1.109, the application can connect to the server successfully.  

Why is that?
[27 May 2014 8:55] Rommel Sanchez
NOT A BUG.

thanks for assistance from irc #mysql