Bug #72741 MySql For Excel Wont Append
Submitted: 25 May 2014 3:24 Modified: 23 Oct 2014 22:49
Reporter: Allen Frantsen Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:MySql For Excel 1.2.1 Workbench 6.1.4 OS:Microsoft Windows (64 bit)
Assigned to: CPU Architecture:Any
Tags: append, Cannot find column, MySQL for Excel

[25 May 2014 3:24] Allen Frantsen
Description:
Trying to append data with the MySql for Excel add in. I highlighted the appropriate data in excel and clicked on "Append Excel Data to Table". An error message comes up and simply says "Cannot find column 4". 

The table I am trying to append is basic, 4 columns of varchar(45) type with one row as the primary key. 

The other tables in the schema seem to append just fine. 

How can I append data for this particular table?

How to repeat:
I am not sure how to repeat this. I tried to export the schema, delete the schema, then import again, but the result is still the same. 

I also tried to delete this particular table and create a new one. The new table still gets the same error in excel.
[2 Jun 2014 21:22] Allen Frantsen
The Schema I am working with

Attachment: FY13.sql (application/octet-stream, text), 8.46 KiB.

[8 Aug 2014 0:58] Javier TreviƱo
Hi Allen, thanks for the bug report.
I looked at the FY13.sql script you attached to this bug, it contains several tables. What is the table to be used to reproduce the issue you reported?

Also it would certainly help to attach a sample Excel spreadsheet containing data to append to the table you specify.

Thanks.
[24 Oct 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".