Bug #72733 EER import/export table inserts data not working
Submitted: 23 May 2014 23:11 Modified: 26 Aug 2014 5:17
Reporter: Diogo Domanski Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:6.1.7 OS:Linux (Ubuntu 14.04 64 bits)
Assigned to: CPU Architecture:Any
Tags: EER, export, import, modeling, workbench

[23 May 2014 23:11] Diogo Domanski
Description:
The import and export records buttons are not working. When clicked, nothing happens. 

How to repeat:
1. Open MySQL Workbench
2. Create a new Model (or open an existing one)
3. Add a new EER Diagram (or open an existing one)
4. Place a new table element
5. Double-click a table element (to open the properties panel)
6. Select "Inserts" tab
7. Click "Import" and/or "Export" buttons

Suggested fix:
These buttons should behave as the same buttons at the Result Grid of the SQL Query panel
[24 May 2014 0:59] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=72530 .
[3 Jun 2014 20:45] Alfredo Kojima
This is not the same as the bug marked duplicate
[13 Jun 2014 10:41] Umesh Shastry
Thank you for the report.
On Win7(not checked on Linux), this is reproducible when there are no columns exists in the table, and export button pops of message complaining no data to be exported where as import button have no effect.

On the other hand - if the table has columns, then both Import/Export works and file dialog pops up when clicked.

On Ubuntu 14.04 LTS

It does nothing no matter table has any column or not both import/export buttons  does nothing.
[4 Jul 2014 23:27] Diogo Domanski
Issue detected on version 6.1.7 of MySQL Workbench for Ubuntu 14.04 64 bis
[26 Aug 2014 5:17] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.2.2 release, and here's the changelog entry:

Clicking "Import" or "Export" from a Model's table properties "Inserts"
tab did not function.

Thank you for the bug report.