Bug #72603 Mysql crashes on install
Submitted: 9 May 2014 23:37 Modified: 17 Jul 2014 20:32
Reporter: Attila Rakosi Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.5.37-0+wheezy1 OS:Linux
Assigned to: CPU Architecture:Any
Tags: install, Stuck, UPDATE

[9 May 2014 23:37] Attila Rakosi
Every time I try to install MySQL with 'sudo apt-get install mysql-server', it freezes on a trigger. I have tried 5 or 6 times with new images. I have tried letting it run for a day. I am using the RASPBIAN 3.12.18+ #680 version on a Raspberry Pi(armv6l). Is it safe to just ctrl-c? what should I do?

I first got this stuck on Sunday May 4th trying to update MySQL. I have asked at raspberry pi forum and someone else said that it is happening to him too (http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=76742).

How to repeat:
sudo apt-get install mysql-server

pi@mcattila ~ $ sudo apt-get install mysql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  heirloom-mailx libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl
  libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.5
  mysql-common mysql-server-5.5 mysql-server-core-5.5
Suggested packages:
  exim4 mail-transport-agent libipc-sharedcache-perl libterm-readkey-perl
Recommended packages:
The following NEW packages will be installed:
  heirloom-mailx libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl
  libmysqlclient16 libnet-daemon-perl libplrpc-perl mysql-client-5.5
  mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 9,895 kB of archives.
After this operation, 91.2 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libaio1 armhf 0.3.109-3 [8,944 B]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-common all 5.5.37-0+wheezy1 [83.1 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libnet-daemon-perl all 0.48-1 [46.2 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libplrpc-perl all 0.2020-2 [36.0 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdbi-perl armhf 1.622-1 [895 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmysqlclient16 armhf 5.1.62-1 [1,828 kB]
Get:7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdbd-mysql-perl armhf 4.021-1 [123 kB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-client-5.5 armhf 5.5.37-0+wheezy1 [1,471 kB]
Get:9 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server-core-5.5 armhf 5.5.37-0+wheezy1 [3,078 kB]
Get:10 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server-5.5 armhf 5.5.37-0+wheezy1 [1,921 kB]
Get:11 http://mirrordirector.raspbian.org/raspbian/ wheezy/main heirloom-mailx armhf 12.5-2 [253 kB]
Get:12 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libhtml-template-perl all 2.91-1 [72.0 kB]
Get:13 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server all 5.5.37-0+wheezy1 [81.4 kB]
Fetched 9,895 kB in 17s (562 kB/s)                                             
Preconfiguring packages ...
Selecting previously unselected package libaio1:armhf.
(Reading database ... 48310 files and directories currently installed.)
Unpacking libaio1:armhf (from .../libaio1_0.3.109-3_armhf.deb) ...
Selecting previously unselected package mysql-common.
Unpacking mysql-common (from .../mysql-common_5.5.37-0+wheezy1_all.deb) ...
Selecting previously unselected package libnet-daemon-perl.
Unpacking libnet-daemon-perl (from .../libnet-daemon-perl_0.48-1_all.deb) ...
Selecting previously unselected package libplrpc-perl.
Unpacking libplrpc-perl (from .../libplrpc-perl_0.2020-2_all.deb) ...
Selecting previously unselected package libdbi-perl.
Unpacking libdbi-perl (from .../libdbi-perl_1.622-1_armhf.deb) ...
Selecting previously unselected package libmysqlclient16.
Unpacking libmysqlclient16 (from .../libmysqlclient16_5.1.62-1_armhf.deb) ...
Selecting previously unselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_4.021-1_armhf.deb) ...
Selecting previously unselected package mysql-client-5.5.
Unpacking mysql-client-5.5 (from .../mysql-client-5.5_5.5.37-0+wheezy1_armhf.deb) ...
Selecting previously unselected package mysql-server-core-5.5.
Unpacking mysql-server-core-5.5 (from .../mysql-server-core-5.5_5.5.37-0+wheezy1_armhf.deb) ...
Processing triggers for man-db ...
Setting up mysql-common (5.5.37-0+wheezy1) ...
Selecting previously unselected package mysql-server-5.5.
(Reading database ... 48694 files and directories currently installed.)
Unpacking mysql-server-5.5 (from .../mysql-server-5.5_5.5.37-0+wheezy1_armhf.deb) ...
Selecting previously unselected package heirloom-mailx.
Unpacking heirloom-mailx (from .../heirloom-mailx_12.5-2_armhf.deb) ...
Selecting previously unselected package libhtml-template-perl.
Unpacking libhtml-template-perl (from .../libhtml-template-perl_2.91-1_all.deb) ...
Selecting previously unselected package mysql-server.
Unpacking mysql-server (from .../mysql-server_5.5.37-0+wheezy1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for menu ...
Setting up libaio1:armhf (0.3.109-3) ...
Setting up libnet-daemon-perl (0.48-1) ...
Setting up libplrpc-perl (0.2020-2) ...
Setting up libdbi-perl (1.622-1) ...
Setting up libmysqlclient16 (5.1.62-1) ...
Setting up libdbd-mysql-perl (4.021-1) ...
Setting up mysql-client-5.5 (5.5.37-0+wheezy1) ...
Setting up mysql-server-core-5.5 (5.5.37-0+wheezy1) ...
Setting up mysql-server-5.5 (5.5.37-0+wheezy1) ...
[ ok ] Stopping MySQL database server: mysqld.
140508 16:51:03 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
140508 16:51:03 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140508 16:51:03 [Note] Plugin 'FEDERATED' is disabled.
140508 16:51:03 InnoDB: The InnoDB memory heap is disabled
140508 16:51:03 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140508 16:51:03 InnoDB: Compressed tables use zlib 1.2.7
140508 16:51:03 InnoDB: Using Linux native AIO
140508 16:51:04 InnoDB: Initializing buffer pool, size = 128.0M
140508 16:51:04 InnoDB: Completed initialization of buffer pool
140508 16:51:04 InnoDB: highest supported file format is Barracuda.
140508 16:51:05  InnoDB: Waiting for the background threads to start
140508 16:51:06 InnoDB: 5.5.37 started; log sequence number 1595675
140508 16:51:06  InnoDB: Starting shutdown...
140508 16:51:07  InnoDB: Shutdown completed; log sequence number 1595675
[ ok ] Starting MySQL database server: mysqld . . . . . ..
[info] Checking for tables which need an upgrade, are corrupt or were 
not closed cleanly..
Setting up heirloom-mailx (12.5-2) ...
update-alternatives: using /usr/bin/heirloom-mailx to provide /usr/bin/mailx (mailx) in auto mode
Setting up libhtml-template-perl (2.91-1) ...
Setting up mysql-server (5.5.37-0+wheezy1) ...
Processing triggers for menu ...

Suggested fix:
Some thing at 'Processing triggers for menu ...' is making it impossible to install.
[11 May 2014 14:53] Attila Rakosi
I still try to install but I still can not install, update, or uninstall/purge. I need MySQL for my website and I can not host my site now.
[17 Jul 2014 20:32] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Unfortunately we do not support Raspberry PI. You should work with their package maintainers. You can try to install our binaries, available from dev.mysql.com/downloads, though. Try "generic Linux" binaries.