Bug #7254 official amd64 binary deadlocks on amd64 (latest debian pure64)
Submitted: 14 Dec 2004 8:54 Modified: 16 Jul 2005 1:59
Reporter: Corin Langosch Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:4.1.7, official amd64 binary OS:Linux (debian amd64 pure64)
Assigned to: CPU Architecture:Any

[14 Dec 2004 8:54] Corin Langosch
Description:
when running the latest official amd64 binary it simple deadlocks on our dual opteron debian pure64 system. 

issuing a "SHOW PROCESSLIST" show a lot of mysql processed with state "LOCKED". uptime shows 0.0 load.

the mysql cant event be killed with "killall -9 mysqld". only rebooting the system helps, but some seconds after the system is up it's the same again. no tables are corrupted, they are just marked as "xx clients didnt close the table properly".

using the official 686 binary on exactly the same configuration works without any problems.

How to repeat:
setup a debian pure64 system.

run the official amd64 binary and wait for the deadock (some seconds).

restart server and install the official 686 binary.

the 686 should work fine  while the amd64 just deadlocks.

Suggested fix:
none
[14 Dec 2004 9:03] Corin Langosch
kernel: Linux xxx 2.6.9-9-amd64-k8-smp #1 SMP Sun Dec 5 01:00:46 CET 2004 x86_64 GNU/Linux
[17 Jan 2005 22:59] Corin Langosch
still happens with official mysql amd64 binanry of 4.1.9.

official mysql 686 binanry of 4.1.9 works fine.

no one else with this weierd problem?!
[18 May 2005 2:30] Lachlan Mulcahy
Hi there,

Do you know if you are using Linuxthreads or NPTL?

Have you tried running the binary that locks up by setting LD_ASSUME_KERNEL=2.4.1 first? This should make it use Linuxthreads which will rule out any issues with NPTL.
[5 Jun 2005 10:03] Hartmut Holzgraefe
Maybe the same problem as bug 8555, although there a kill -9 works ...
[16 Jun 2005 1:59] Stewart Smith
JimW recently blogged about Ubuntu Hoary Hedgehog on amd64 having a pthread_rwlock_wrlock() bug. Since Ubuntu is derived from debian, perhaps the debian packages still have this bug too and this is the cause of this problem?

http://trainedmonkey.com/entry/2248

and the ubuntu bug:
https://bugzilla.ubuntu.com/show_bug.cgi?id=11730

Jim reported the Ubuntu bug and mentions that this was causing tests in MySQL 4.1 to fail (specifically auto_increment).

It's possibly worth you running the 'make test' suite to see if this problem arises.
[16 Jul 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".