Bug #72324 Contextual help does not work at all
Submitted: 12 Apr 2014 9:41 Modified: 21 Aug 2014 0:05
Reporter: Juan García Martel Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.1.4 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 build 7601, 64-bit)
Assigned to: CPU Architecture:Any
Tags: regression, WBBugReporter

[12 Apr 2014 9:41] Juan García Martel
Description:
Contextual help does not work any more.

How to repeat:
Edit a function, procedure or trigger, then place the cursor over any Mysql functions you hare using, like max(), radians(), etc. and you will not get contextual help about this function in the right pannel like it worked before.

Suggested fix:
Repair contextual help which is very useful while developing.
[14 Apr 2014 10:36] Umesh Shastry
Hello Juan,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[17 Apr 2014 20:04] Alfredo Kojima
The context help was changed so that you have to either click the ? button or enable automatic help, in the toolbar.

However, because it's confusing we'll add a message explaining that.
[12 May 2014 13:59] Johannes Taxacher
Posted by developer:
 
automatic context help now works properly in all editors, but the on-demand button doesn't show the proper reaction (when automatic context-help is turned off)
[21 Aug 2014 0:05] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.2.1 release, and here's the changelog entry:

The automatic context help did not always function in the SQL editor.

Thank you for the bug report.