Bug #72283 InnoDB: Assertion failure in file fil0fil.c
Submitted: 9 Apr 2014 7:23 Modified: 3 May 2018 9:50
Reporter: nobuaki mochizuki Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.5.27 OS:Linux (CentOS release 5.8 / 2.6.18-308.13.1.el5)
Assigned to: CPU Architecture:Any

[9 Apr 2014 7:23] nobuaki mochizuki
Description:
InnoDB: Assertion failure in thread 1332676928 in file fil0fil.c line 4578
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=404750336
read_buffer_size=4194304
max_used_connections=0
max_threads=300
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 2856328 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/usr/local/mysql/bin/mysqld(my_print_stacktrace+0x35)[0x7a61c5]
/usr/local/mysql/bin/mysqld(handle_fatal_signal+0x403)[0x673a13]
/lib64/libpthread.so.0[0x3117c0ebe0]
/lib64/libc.so.6(gsignal+0x35)[0x3117430285]
/lib64/libc.so.6(abort+0x110)[0x3117431d30]
/usr/local/mysql/bin/mysqld[0x8639cc]
/usr/local/mysql/bin/mysqld[0x83d2f5]
/usr/local/mysql/bin/mysqld[0x83dbf7]
/usr/local/mysql/bin/mysqld[0x830713]
/usr/local/mysql/bin/mysqld[0x820ba5]
/usr/local/mysql/bin/mysqld[0x8249a6]
/usr/local/mysql/bin/mysqld[0x879bd7]
/usr/local/mysql/bin/mysqld[0x83db86]
/usr/local/mysql/bin/mysqld[0x87614a]
/usr/local/mysql/bin/mysqld[0x876217]
/usr/local/mysql/bin/mysqld[0x7e8125]
/lib64/libpthread.so.0[0x3117c0677d]
/lib64/libc.so.6(clone+0x6d)[0x31174d3c1d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
truncate huge table.
over 600000000 records.
[9 Apr 2014 12:11] Miguel Solorzano
Thank you for the bug report. Please check with latest release 5.5.37 and comment here the result. Thanks.
[10 May 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[26 Oct 2014 22:04] Michael Hampton
Still occurring on 5.5.40.

This occurred when attempting to restart after a hard power failure. Something is corrupted but I can't tell exactly what.

I can bring up MySQL with innodb_force_recovery=3.
[7 Oct 2015 5:17] Shahriyar Rzayev
Affected as 5.5.45 version.
[8 Feb 2016 21:15] Karu Donaldson
Seeing the same issue on:
mysql  Ver 14.14 Distrib 5.5.42, for osx10.6 (i386) using  EditLine wrapper

I backed up and deleted ib* files under
/Applications/MAMP/db/mysql/

Restarted mamp and mysql started again.
[8 Sep 2016 17:50] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=82911 marked as duplicate of this one.
[3 May 2018 9:50] Miguel Solorzano
I couldn't repeat with current source server. Sorry for the delay. Thanks.