Bug #72257 Odd behaviour of object info popovers in diagrams
Submitted: 6 Apr 2014 17:32 Modified: 18 May 2014 12:10
Reporter: Nils Waldherr Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:6.1.4 OS:Any
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[6 Apr 2014 17:32] Nils Waldherr
The litre tooltip-like popovers in diagrams get in the way in various ways: 

They appear regardless of mouse action like moving, clicking or dragging so for instance moving an object to the right a bit is impossible due to a big popover that gets in the way.

Highlighting relations on mouseover collides with popovers as well as it is impossible to keep the popover from being displayed.

Also the popovers are system- (not application-) modal and they do not hide on application switch. Even now, typing this bug report in Safari I have a popover displayed in front of my browser window. 

How to repeat:
Proceed like stated in the description.

Suggested fix:
- First of all: Preference to disable popovers globally
- activate popover only when mouse is idle (no button pressed, no moves for x seconds)
- hide popover on any mouse action (click, move, drag)
- hide on application switch (or set modality correctly)
- respect application focus, only react on mouse if application has focus
[8 Apr 2014 17:17] Miguel Solorzano
Thank you for the bug report.
[26 Apr 2014 16:13] Michal Koscielny
Let me vote for this bug - it should not be under "Mac OS X" but under "Any" since this problem is on Windows, too.

These tooltips are not thought out well as they usually don't provide any useful information and obscure the view of the diagram. And, what is worse, hovering over a table header is the only way to highlight all relationships with other tables (the joining lines light up in different colours) - but when I want to view them then the tooltip comes up and prevents me from seeing the connections!

In my opinion the most important fix is to be able to disable these tooltips completely.

Other than that I think they should be designed differently from the start because the tooltip format is quite awkward and inconvenient (e.g. when there are many columns in a table the tooltips don't fit on the screen and information is lost, can't copy from the tooltip):

1. Add a small icon on the table header bar, for example next to the arrow we have now on the right. Or, simply make the current table icon clickable that is situated on the left.
2. Clicking the icon would toggle the display of table structure info but not in a tooltip but in a layered box, which would allow me to scroll if the information does not fit in and also to select and copy text from there.
[26 Apr 2014 16:47] Michal Koscielny
After a while I've noticed that these tooltips cause even more usability problems. Very often (in about 50% of cases) the tooltips prevent me from moving tables on the diagram - when I'm moving a table with the mouse button pressed and I go with the cursor over the tooltip the table suddenly jumps to the top left corner of the screen and it gets back to its proper position under the cursor only when I move out of the tooltip area.

So taking this problem into account making the tooltip optional is not enough, I think. There should also be some fix so that the tooltip doesn't make moving tables a headache.
[6 May 2014 14:32] Johannes Taxacher
Posted by developer:
fix confirmed in now tooltips get out of the way as soon as mouse movement/clicks are registered, as well as when switching applications.
[14 May 2014 23:05] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.1.6 release, and here's the changelog entry:

In the EER diagram editor, tooltips are now hidden when mouse movements or
clicks are registered, and they are also hidden when switching

Thank you for the bug report.
[18 May 2014 12:10] Nils Waldherr
Thank you for the quick response!

[18 Jun 2014 15:58] Normen Müller
It's much better now, but why can't we disable those tooltips at all or only fire them up with a key + mouse click combination? That would be even better. I'm on OSX.