Bug #72226 Descending column sort in result grid not working (only sorts ascending).
Submitted: 3 Apr 2014 16:27 Modified: 14 May 2014 4:28
Reporter: Joe Beason Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version: OS:Microsoft Windows (Win 7 SP1 64-bit)
Assigned to: CPU Architecture:Any
Tags: regression

[3 Apr 2014 16:27] Joe Beason
When clicking on any column header in the result grid, the data will sort ascending (lowest to highest), but will not sort descending (highest to lowest) when clicked again. Clicking on a column header alternately used to sort the data ascending or descending.

How to repeat:
select any result set and click on a column header to sort. The data will only sort ascending NOT descending.
[4 Apr 2014 8:32] Umesh Shastry
Hello Joe,

Thank you for the bug report.
Verified as described.

[7 Apr 2014 21:01] Godofredo Miguel Solorzano
http://bugs.mysql.com/bug.php?id=72266 duplicate of this one.
[14 May 2014 4:28] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.1.6 release, and here's the changelog entry:

Clicking a column header in an SQL result view sorts rows in ascending
order, but clicking the column header a second time would not sort the
rows in descending order.

Thank you for the bug report.