Bug #72203 SQL Editor Result Grid continually disappears
Submitted: 1 Apr 2014 21:18 Modified: 19 Aug 2014 15:11
Reporter: Mike Reid Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.1.7 GA OS:Any
Assigned to: CPU Architecture:Any

[1 Apr 2014 21:18] Mike Reid
Testing the latest changes in the 6.1.3 beta, I have noticed a very frustrating new bug in which executed SQL queries results are not visible. The Result Grid panel either never shows up, or disappears...

It does not happen every time, but consistently enough to become a pain.

Jumping between tabs and executing various queries (via Command + Return) is part of my general workflow. I have not been able to isolate exact behavior to repeat, but it happens quite often.

How to repeat:
1. Connect to database

2. Begin issuing various SELECT statements, using multiple tabs, etc (Use Command + Return hot key to execute query)

3. Watch as the Action Output lists row(s) returned and total duration, but the Result Grid is no longer visible.

4. Opening a new tab and re-running the query seems to fix temporarily, but at random, the Result Grid will continue to disappear failing to show the results of your query.

Suggested fix:
Ensure "Result Grid" panel is always visible under all scenarios involving the display of output from the database server.
[1 Apr 2014 22:34] Mike Reid
I did not see that 6.1.4 GA had landed. I will leave this bug open for the next week while I test on that build, and will close it in the event has already been fixed.
[1 Apr 2014 23:33] MySQL Verification Team
Thank you for the bug report. Please try version 6.1.4 if still you get the same
issue please provide a screenshot about. Thanks.
[2 Apr 2014 17:26] Mike Reid
Updated impacted version to 6.1.4 GA

Just had my first occurrence of this bug on 6.1.4. I continually execute the query, but the Result Grid is not visible.

In my screenshot you'll see the multiple attempts (16 total) I ran the query. The Results Grid was showing up fine for the earlier results where 1 row was returned, and the first few records showing 2 row(s) returned... then the results just disappeared.
[2 Apr 2014 17:26] Mike Reid

Attachment: MySQL_Workbench_bug_72203_screenshot.jpg (image/jpeg, text), 567.18 KiB.

[3 Apr 2014 12:50] Alfredo Kojima
Can you move the mouse at the bottom of the sql editor area and see if you can resize the resultset up? Maybe it's getting resized to 0 height.
[3 Apr 2014 17:00] Mike Reid
This happened again to me just now... (different query, new connection, etc)

It is tricky to get just right, but it seems like that is what's happening. If I position my cursor JUST right, I can get it to turn into an UP ARROW (vs. and UP and DOWN ARROW). Once that happens, you can "drag up" and the Result Grid becomes visible again.

Any idea on why the height would be resetting to zero, seemingly at random?
[17 Apr 2014 11:09] Pete Walker
This is happening for me too - and it's definitely getting resized to 0 height - I can bring it back.

Yet to find a consistently reproducible method.

Video of it happening: https://vimeo.com/92229121
[7 May 2014 16:06] Mike Reid
Thank you for posting the video, Pete. That is exactly what is happening here, seemingly at random.

@Workbench devs, has this issue been confirmed yet from your end? This is making MySQL Workbench particularly frustrating to use, and I am curious if there is a known fix or recommendation that can be applied ahead of waiting for the next release?
[10 May 2014 21:07] Nick Endle
Happening for me too, OSX Mavericks and version 1454. When pressing the Execute Query button (or using the hotkey) the result grid jumps down (as it normally does) but doesn't come back up to display the results.

If I close every tab I have open and then open a fresh tab, it starts working again.
[18 May 2014 14:20] Martin Peter
I can confirm this bug here with Workbench on Mac OSX
[20 May 2014 1:34] Saxifrage Cucvara
I, too, have been having this problem constantly. I'm using MySql Workbench 6.1.4 on a Mac OS X 10.8.

I am able to reproduce the problem quite regularly by:
Opening up a database
Right clicking on a table to do an automatic 'Select Rows - Limit 1000'.
The table will open up no problems.
If I then type in a different query into the same window then the Result Grid disappears.
I have to copy and paste my query into a blank SQL window for it to work.

This is really frustrating too! Especially as the seemingly obvious problem was very difficult to Google properly!
[20 May 2014 1:42] Mike Reid
Updated impacted version to v6.1.6.
[22 May 2014 7:30] Henrik Verup
I am also affected by this bug. It is very frustrating and I am therefore turning to Oracle SQL Developer even though this is not a better tool for MySQL.
I am using MySQL Workbench Community (GPL) for Mac OS X version 6.1.4  revision 11773 build 1454 on OS: OS X 10.9.x Mavericks
CPU: 8x Intel(R) Core(TM) i7-4960HQ CPU @ 2.60GHz - 16.00GiB RAM
[22 May 2014 10:52] Eric Nichols
Ditto. This happens to me quite consistently. Note that if I right-click a table in the list of tables under the Schema in the last-hand column and do "Select Rows", I never see the bug. It only happens when executing my own SQL by clicking the lightning bolt.

And for me, it happens the majority of the time, not just rarely. It renders the MySQLWorkbench almost unusable for all but the most basic tasks. Hope someone can solve this one!! I'm using build 1642
[26 May 2014 21:16] Peter Benci
same behaviour as described in previous comments. Mac OSX 10.9.2 with MySQL Workbench build 1454
[28 May 2014 8:04] David Schneider
I can confirm the issue with Mac OSX 10.9.3 and Mysql Workbench

Please do something about it, its making my work very painful.
[28 May 2014 18:34] Samuel Oldak
Affects me 100% of the time. OSX 10.9.3, MySQL Workbench
[28 May 2014 18:36] Mike Reid
Bumping to Critical. At the very least would like to see this bug verified by the devs, I've reached out via multiple channels now.

Tempted to roll-back to 6.1.2 (pre-GA) or start looking into alternate solutions. This bug is crippling.
[28 May 2014 23:49] Chip Allen
I'm also getting it and agree that this needs to be fixed ASAP - makes the tool unusable. I'm on 6.1.4.
[28 May 2014 23:56] Eric Nichols
Glad to see it's not just me. 

I now rolled back to 6.0.9 until further notice since this became unusable.
[30 May 2014 13:14] Richard Malina
I found a workaround.  Hit the "Explain" button first (Magnifying glass over bolt); this will open an Explain tab.  After the explain tab is open, the normal query does not resize the result grid improperly.
[30 May 2014 17:49] Mike Reid
Interesting...when the Result Grid refreshes, the previous query's result tab is destroyed, then recreated (indicated by a numeric counter for each subsequent execute.) It seems by keeping the "Explain" tab present, it temporarily falls back to it (or any remaining lower tabs) before showing the new results, thus preserving the Result Grid panel's height.

I can confirm this as a valid workaround, however it is limited to the current SQL Query tab. Thanks Richard!
[3 Jun 2014 6:18] Graham Charlton
I have found that if you turn off the bottom pane you can then drag the results window up with the cursor. If the bottom pane is visible, you can't get the cursor to find the right place to drag.

Hope this helps.
[6 Jun 2014 4:16] Bernie van't Hof
Definitely a show stopper. Driving me nuts.

Re closing bottom panel and dragging results window: 
Works, but has to be repeated for each query execution, perhaps because a new results tab is being generated each time.
[10 Jun 2014 20:14] Henrik Verup
It would indeed very nice to hear from Support, what and when this bug will be fixed?
As another workaround, I have found a free version of the TOAD application in App Store. It was initially developed for Oracle databases, but it can also be used with MySql and is quite a good editor.
[18 Jun 2014 15:39] gary smith
Happening here with OSX 10.9.3 and WB Build 1642.

Thank to Richard Malina for the workaround.
[25 Jun 2014 19:13] Maxime Laberge
Affecting me on OSX Mavericks as well. I am not affected on Windows 7 on my PC.

Richard's workaround helps for now!
[30 Jun 2014 17:20] Mike Reid
Updated impacted version. I can confirm this bug is still present on 6.1.7 GA.
[3 Jul 2014 3:31] Jeremy Todd
I can also confirm that this bug is still present in 6.1.7 on OS X 10.9.3. It is indeed very frustrating!
[4 Jul 2014 18:16] jay marm
same issue.  using sql v 5.5, workbench v 6.1.7 build 1788

result grid blank. the only way to look at the data is via the form editor.
[4 Jul 2014 18:22] jay marm
ooops... sorry, I missed the Mac OS part.  I'm running on ubuntu 14.04 with a display resolution of 1360x768 (yah weird I know.. but it runs on a 32" LCD just fine).
[4 Jul 2014 18:33] Mike Reid
Thanks, Jay. Updating the issue to mark OS "Any." Perhaps this will help provide more attention to this issue in hopes of getting it resolved.
[15 Jul 2014 2:46] jay marm
FYI... after trying several different things to try and get workbench working eg. installing various display drivers - all unsuccessful - I've given up and have installed Squirrel SQL instead. http://www.squirrelsql.org/#installation Figuring out how to get it up and working took some doing... like why it doesn't have some built-in feature to download whatever jdbc drivers you want (ie: it comes with none!)?!? The UI isn't anywhere near as intuitive as workbench, but it'll do the job - and bottom line it displays the data!

Guide: http://www.squirrelsql.org/kulvir/tutorial.html
[15 Jul 2014 16:30] Maxime Laberge
Commenting to let your know that there is a Verified(status) version of the bug report here: http://bugs.mysql.com/bug.php?id=72897
[15 Jul 2014 16:35] Mike Reid
Thanks Maxime. I left a note on that issue to note as "Related."
[15 Aug 2014 23:28] Alfredo Kojima
I can repeat by querying a larger table and disabling the row Limit feature. Seems to be some kind of race. I'm marking this as a duplicate of the other already verified bug #72897
[19 Aug 2014 15:11] Mike Reid
I am using the new 6.2.1 BETA, and it appears that this issue has been fixed.

I will report back after more use, but so far so good! :)

[25 Aug 2014 9:07] Jonas Hutzenlaub
Result Grid is not yet visible in 6.2.1 BETA on Ubuntu 14.04.
[25 Aug 2014 20:55] jay marm
"[25 Aug 9:07] Jonas Hutzenlaub: Result Grid is not yet visible in 6.2.1 BETA on Ubuntu 14.04"

Same here... still no worky using the 6.2.1 beta.

[27 Aug 2014 23:10] Ched Cheatham
What a pain.
[4 Sep 2014 15:23] Roy Hill-Percival
This is resolved (at least for OS X) as of the upcoming MySQL Workbench Release 6.2.2 release.

official ref: http://bugs.mysql.com/bug.php?id=72897
[15 Sep 2014 14:54] Jonas Hutzenlaub
unfortunately not fixed in MySQL Workbench Community (GPL) for Linux/Unix version 6.2.2  revision 12242 build 2167 (64 bit)
[26 Oct 2014 15:14] Keith Winkler
Ubuntu 14.10, workbench 6.2.3, grid results panel visible, but rows are never visible.

Attachment: ubuntu_14_10_workbench_6.2.3.12312.png (image/png, text), 112.65 KiB.

[27 Oct 2014 18:52] Drew Dormann
I can attest to the report and image supplied by Keith Winkler.

On Ubuntu 14.10 the "Result Grid" is completely missing.  The "Alter Table" view is also gone.
[29 Oct 2014 12:46] Chef Jean
Idem Keith and Drew.

After select statement : no data displayed in "Result grid", no action displayed in "Action output".

Kubuntu 14.10, workbench 6.1.7 and 6.2.3
[29 Oct 2014 15:27] Casey McMullen
Happening to me on a fresh/from-scratch install on Ubuntu 14.10.  Result grid is not showing data (although the data will appear in the Form Editor view, so I know it's there).  The Action Output window is also not reporting anything.
[30 Oct 2014 3:08] Casey McMullen
Downgraded from 14.10 to Ubuntu 14.04 LTS and installed latest MySQL Workbench version and all works well.  Apparently the problem with the disappearing Result Grid (at least for me) is some bug in Ubuntu 14.10, not Workbench.
[30 Oct 2014 10:36] Gilberto de Almeida
I got the same problem after upgraded to Ubuntu 14.10
[30 Oct 2014 16:24] Drew Dormann
For the benefit of others who end up here, this seems to be an issue with the version of GLib packaged with Ubuntu 14.10 - GLib 2.42.

It's (hopefully) getting attention in Ubuntu's Launchpad here.  https://bugs.launchpad.net/ubuntu/+source/mysql-workbench/+bug/1155571

The problem is apparently solvable by either downgrading GLib - which would happen if you downgraded to Ubuntu 14.04 - or by applying the patch to GLib mentioned here.  http://bugs.mysql.com/bug.php?id=74147
[11 Nov 2014 19:16] Casey McMullen
If you want to patch and build mysql-workbench yourself, you can:

1. Get the source from for 6.2.3 from http://dev.mysql.com/downloads/file.php?id=453799

2. Navigate to the directory you downloaded it to.

3. tar xvf mysql-workbench-community-6.2.3-src.tar.gz

4. cd mysql-workbench-community-6.2.3-src

5. wget -O patch-glib.diff http://bugs.mysql.com/file.php?id=21874&bug_id=74147

6. patch -p0 < patch-glib.diff

7. sudo apt-get build-dep mysql-workbench

8. sudo apt-get install libgdal-dev

9. cd build

10. cmake .. -DBUILD_CONFIG=mysql_release

11. make       (go get lunch on this step, it takes a while)

12. sudo make install
[28 Jan 2015 17:14] César González
Thank you very much Casey McMullen. It works!!!