Bug #72145 Connector.NET msi installer fails
Submitted: 27 Mar 2014 14:01 Modified: 21 Jun 2014 22:52
Reporter: Tim Salter Email Updates:
Status: No Feedback Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.8.3 OS:Microsoft Windows (WIndows 7)
Assigned to: Assigned Account CPU Architecture:Any
Tags: installer, Web providers

[27 Mar 2014 14:01] Tim Salter
Description:
On running the installer, the installer fails and rolls back with no explanation and nothing obvious in the installation log (attached below).

N.B. The installer WILL run if a custom install is selected, and "Web providers" is disabled.

How to repeat:
Uninstall all other MySQL components (to start on a clean machine).
Run the 6.8.3 install msi file.

Suggested fix:
If the installer requires some external actions in order to be successful, then it should report what they are.

I have searched for similar problems in previous versions, tried suggested workrounds,but none seem to be successful in this case.
[21 May 2014 22:52] Roberto Ezequiel Garcia Ballesteros
Hi Tim

Could you please help me to do some test to determine the reason of the problem?

Steps are very easy to follow:

1. Download and unzip mysql-connector-net-6.8.3-noinstall.zip from here:

http://dev.mysql.com/get/Downloads/Connector-Net/mysql-connector-net-6.8.3-noinstall.zip

2. Open a Command Prompt window as Administrator and change directory to <mysql-connector-net-6.8.3-noinstall.zip path>\v2.0

3. Run: 
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\installUtil.exe" MySql.Web.dll

4. Please post the result

Thank you.
[22 Jun 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".