Bug #72070 actual configuration-file search not as documented
Submitted: 18 Mar 2014 19:25 Modified: 19 Mar 2014 14:00
Reporter: Programmer Old Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.6.14-log OS:Microsoft Windows (Vista)
Assigned to: CPU Architecture:Any

[18 Mar 2014 19:25] Programmer Old
Description:
See http://dev.mysql.com/doc/refman/5.6/en/option-files.html

I find that for "mysql.exe" and "mysqldump.exe"
%PROGRAMDATA%\MySQL\MySQL Server 5.6\my.ini
is not used. Changes made to that file affect the server, but that is read through a command-line option, right?

Instead,
INSTALLDIR\my.ini
is read.

(I have not try'd ".cnf" instead of ".ini".)

(Maybe this is akin to bug #71419.)

How to repeat:
Under Vista, remove all option files but
%PROGRAMDATA%\MySQL\MySQL Server 5.6\my.ini
and see whether setting "prompt" affects "mysql.exe", or setting "compact" affects "mysqldump". Afterwards also try the same in
INSTALLDIR\my.ini
.

Suggested fix:
Change the documentation to match the programs, or the programs to match the documentation. The latter is certainly better, for one expects more changes under "\ProgramData" than under "\Program Files".
[19 Mar 2014 14:00] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=68797 .