Bug #72026 Second connection
Submitted: 12 Mar 2014 17:03 Modified: 21 Aug 2014 1:51
Reporter: Matthias Maier Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.0.9, 6.1.2 OS:Microsoft Windows (Win 7 SP1)
Assigned to: CPU Architecture:Any
Tags: Connection

[12 Mar 2014 17:03] Matthias Maier
Description:
Every time I connect to the database with MySQL Workbench two connection are opened simultaneously. Other DBMS Tools open just one connection.

How to repeat:
Open in Home Tab a connection. Go to Navigator -> Management -> Client Connections and look for connections from your host (in most cases these connections will have almost the same connection id number).

Suggested fix:
Clarify why a second connection is needed or use just one connection.
[20 Mar 2014 8:28] Umesh Shastry
Hello Matthias,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[17 Apr 2014 20:55] Alfredo Kojima
Workbench needs 2 connections so that one connection can be used for user queries and another for internal queries, without state changes in one connection interfering the other.
[17 Apr 2014 20:56] Alfredo Kojima
If there's a strong reason to require that only 1 connection be used, please provide the reasoning so we can treat it as a feature request. Otherwise, I'd like to close this as Not a Bug.
[22 Apr 2014 6:06] Matthias Maier
There is no strong reason but I wondered why two connections are needed. It should be clarified in the documentation that there need at least two connections. (In my case I allowed only one connection for a privileged user. In all other DBM programs that was fine but workbench did not work properly.) In my opinion it would be helpful that workbench additional displays a warning if it is not possible to open two connections at the same time.
[10 Jul 2014 2:25] Alfredo Kojima
Posted by developer:
 
Good point, not displaying a clear error when the 2nd connection fails is a bug.
[20 Aug 2014 14:02] Johannes Taxacher
Posted by developer:
 
fix confirmed in 6.2.1.
[21 Aug 2014 1:51] Philip Olson
Fixed as of the MySQL Workbench 6.2.0 release, and here's the changelog entry:

A specific error message was added for failed MySQL connections when the
"max_user_connections" limit was reached.

Thank you for the bug report.