Bug #71968 Unicode (Greek Polytonic) Garbled Characters
Submitted: 7 Mar 2014 10:56 Modified: 7 Aug 2014 22:43
Reporter: Matthew Barron Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:1.2.0 OS:Microsoft Windows (Windows 7 Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: charset, encoding, garbled text, greek characters, Unicode, UTF-8

[7 Mar 2014 10:56] Matthew Barron
Description:
When committing fields through Excel into the MySQL database, the characters are not encoded correctly (or something) and are stored as garbled text. For example, when typing 'Γενέσεως' in an Excel field, committing the new record, then retrieving the records from MySQL, all I receive back is 'Ge?es??'.

The database is collocated as 'utf8_general_ci'. The tables are explicitly collocated so as well.

No sufficient answer was given to resolve this in the forums (so far as I could see.)

I am currently running MySQL Community Server 5.5.24, Microsoft Excel 2007.

How to repeat:
Screenshot 1: http://adfontespress.com/errors/001.jpg
Screenshot 2: http://adfontespress.com/errors/002.jpg
Screenshot 3: http://adfontespress.com/errors/003.jpg

Suggested fix:
I'm clueless as to a fix. Would appreciate a workaround that's easy and that doesn't require going through the MySQL client.
[7 Aug 2014 22:36] Javier Treviño
Can't reproduce in latest version (1)

Attachment: Bug71968-1.png (image/png, text), 91.87 KiB.

[7 Aug 2014 22:36] Javier Treviño
Can't reproduce in latest version (2)

Attachment: Bug71968-2.png (image/png, text), 94.11 KiB.

[7 Aug 2014 22:36] Javier Treviño
Can't reproduce in latest version (3)

Attachment: Bug71968-3.png (image/png, text), 15.98 KiB.

[7 Aug 2014 22:36] Javier Treviño
Can't reproduce in latest version (4)

Attachment: Bug71968-4.png (image/png, text), 107.85 KiB.

[7 Aug 2014 22:37] Javier Treviño
Can't reproduce in latest version (5)

Attachment: Bug71968-5.png (image/png, text), 94.17 KiB.

[7 Aug 2014 22:42] Javier Treviño
Thanks for the bug report Matthew.
I added 5 screenshot images to this bug testing in the currently released version of MySQL for Excel (1.3.1), and I could successfully use the Edit Data feature on a table with encoding utf8_general_ci inserting a new row with Greek text.

I see you reported this on 1.2.0, and I am pretty sure that this bug is fixed since version 1.2.1.  Please test again using preferably the latest version that you can get from http://dev.mysql.com/downloads/windows/excel/
[7 Aug 2014 22:43] Javier Treviño
Thank you for your bug report. This issue has already been fixed in the latest released version of MySQL for Excel that you can get from:

http://dev.mysql.com/downloads/windows/excel/