Bug #71752 Add example to create a compressed image
Submitted: 17 Feb 2014 12:23 Modified: 25 Nov 2014 15:10
Reporter: Daniël van Eeden (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Enterprise Backup Documentation Severity:S3 (Non-critical)
Version:3.9.0 OS:Any
Assigned to: Daniel So CPU Architecture:Any

[17 Feb 2014 12:23] Daniël van Eeden
Description:
http://dev.mysql.com/doc/mysql-enterprise-backup/3.9/en/backup.compressed.html
http://dev.mysql.com/doc/mysql-enterprise-backup/3.9/en/meb-backup-single-file.html
http://dev.mysql.com/doc/mysql-enterprise-backup/3.9/en/meb-backup-streaming.html

Besides the --compress option it's also possible to create a compressed backup with:
mysqlbackup --backup-image=- backup-to-image | gzip > backup_image.mbi.gz

This can also help if you're streaming large backups with netcat:
Sender:
mysqlbackup --backup-image=- backup-to-image | gzip | nc backupserver 1234

Receiver:
nc -l -p 1234 | gzip -d > backup_image.mbi
OR
nc -l -p 1234 > backup_image.mbi.gz

How to repeat:
See description.
[18 Feb 2014 19:42] Sveta Smirnova
Thank you for the reasonable docs request.

Although I think there are dozens of programs you can stream backup image to.
[25 Nov 2014 15:10] Daniel So
We recommend using the --compress option for creating a compressed backup image, and an example of doing so (and streaming the image to a remote host) can already found in 3.3.5.1, Streaming the Backup Data to Another Device or Server (http://dev.mysql.com/doc/mysql-enterprise-backup/3.11/en/meb-backup-streaming.html).