Bug #7163 Test failure: 'client_test' when using '--embedded-server'
Submitted: 10 Dec 2004 11:12 Modified: 2 Jan 2005 15:14
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
Category:MySQL Server Severity:S2 (Serious)
Version:4.1.8-pre OS:Unix/Linux (various)
Assigned to: Alexey Botchkov CPU Architecture:Any

[10 Dec 2004 11:12] Joerg Bruehe
(This is _no_ duplicate of #6275, as it occurs only with the '--embedded-server' option.)

With a fresh pull of 4.1.8 this morning (latest changeset: 
 1.2158 04/12/10 02:36:45 heikki@hundin.mysql.fi +1 -0
  dict0dict.c:     Fix the bug that the character 0xA0 that EMS MySQL Manager ...)
I ran the test suite on my PC (Linux, x86, gcc 3.3).

It passed for the default options and with '--ps-protocol', but had failures with '--embedded-server' which I now report individually.

For 'client_test', the report is:
=== cut ===
Errors are (from /M41/push-4.1/mysql-test/var/log/mysqltest-time) :
mysql_embedded: command "$TESTS_BINDIR/client_test --no-defaults --testcase --user=root --socket=$MASTER_MYSOCK --port=$MYSQL_TCP_PORT --silent" failed
(the last lines may be the most important ones)
=== cut ===

This is identical to the reports I got on _all_ of our build platforms on which I tried the 'embedded' tests:
'aix43', 'barney', 'buildqnx', 'cane', 'hpux11'(32), 'intelxeon', 'pegasos1', 'powermacg4', 'powermacg5', 'sol9x86', 'sunfire100b', 'sunfire100c'. 

How to repeat:
Run the test suite with '--embedded-server'.
[2 Jan 2005 15:14] Alexey Botchkov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at