Bug #7155 mysqld_multi don't accept log option in my.cnf
Submitted: 10 Dec 2004 5:58 Modified: 23 Feb 2005 3:01
Reporter: Faris Xiao Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:4.0.22 OS:Linux (Redhat AS 3)
Assigned to: Jim Winstead CPU Architecture:Any

[10 Dec 2004 5:58] Faris Xiao
Description:
my.cnf

[mysqld_multi]
mysqld     = /usr/local/mysql/bin/mysqld_safe
mysqladmin = /usr/local/mysql/bin/mysqladmin
user       = multi_admin
password   = multipass
log  =   /mysqldata/mysqld_multi.log
......
[mysqld]
datadir    = /mysqldata

when I use mysqld_multi ,the log file don't appera at /mysqldata/mysqld_multi.log,but at /mysqldata/mysqld_multi.log

How to repeat:
always repeat.

Suggested fix:
modifiy the mysqld_multi file,add one if judge.

diff :

150,151d149
< if (!defined($opt_log))
<  {
182d179
<  }
[5 Jan 2005 17:20] Victoria Reznichenko
Hi,

Thank you for the report, but seems you made a typo in the log file names.
Could you please clarify it?

I tested it on my box and it works like a charm for me.
[6 Jan 2005 2:14] Faris Xiao
my my.cnf

Attachment: my.cnf (application/octet-stream, text), 6.24 KiB.

[6 Jan 2005 2:14] Faris Xiao
my my.cnf

Attachment: my.cnf (application/octet-stream, text), 6.24 KiB.

[6 Jan 2005 2:38] Faris Xiao
I had upload my my.cnf.

Becuase the slow net speed,I click the upload button twice. I'd upload the same file twice,sorry.

The step of repeat the bug in my server.
1. rm /mnt/sdb7/77dbmysqldata/mysqld_multi.log
2.rm  /mysqldata/mysqld_multi.log
3.mysqld_multi report
4.the log file appear in /mnt/sdb7/77dbmysqldata/mysqld_multi.log,but it should be appear at /mysqldata/mysqld_multi.log
[10 Jan 2005 18:49] Victoria Reznichenko
Thank you for feedback.

I still can't reproduce it.

How did you install MySQL server from binary or from source distribution?
If you use binary distribution, is it official MySQL distribution or it comes with Red Hat?
[11 Jan 2005 2:59] Faris Xiao
I installed MySQL server from source distribution.

I used the following configure options:

CFLAGS="-O9 -mcpu=pentium4 -fomit-frame-pointer -fomit-frame-pointer -fno-exceptions -fno-rtti" CXX=gcc CXXFLAGS="-O9 -mcpu=pentium4 -felide-constructors -fomit-frame-pointer -fno-exceptions -fno-rtti" ./configure --prefix=/usr/local/mysql4.0.22  --enable-assembler --with-extra-charsets=none --disable-shared --with-client-ldflags=-all-static --with-mysqld-ldflags=-all-static --without-innodb --without-bench --without-isam  --without-readline  --without-docs  --without-debug --disable-largefile --enable-local-infile

The installed perl rpm package in my server is :

[faris@beijingdb faris]$ rpm -qa|grep perl
perl-Parse-Yapp-1.05-30
perl-libxml-perl-0.07-28
perl-XML-Grove-0.46alpha-25
perl-5.8.0-88.4
perl-Filter-1.29-3
perl-DateManip-5.40-30
perl-HTML-Parser-3.26-17
perl-URI-1.21-7
perl-XML-Parser-2.31-15
perl-XML-Dumper-0.4-25
perl-libxml-enno-1.02-29
perl-XML-Twig-3.09-3
perl-SGMLSpm-1.03ii-11
perl-CPAN-1.61-88.4
perl-HTML-Tagset-3.03-28
perl-libwww-perl-5.65-6
perl-XML-Encoding-1.01-23
[11 Jan 2005 3:06] Faris Xiao
The patched mysqld_multi,it can accept log option in my.cnf

Attachment: mysqld_multi.faris (text/plain), 19.95 KiB.

[14 Feb 2005 22:54] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[18 Feb 2005 1:46] Faris Xiao
I'd feedback.
[18 Feb 2005 1:47] Faris Xiao
How to change the Status to open?
Can I do it?
[18 Feb 2005 1:47] Faris Xiao
Please open this bug!
[18 Feb 2005 22:30] Jorge del Conde
Thanks for your bug report

Verified using 4.0.23 - x86

root-/my/multi# cat /etc/my.cnf
[mysqld_multi]
mysqld     = /usr/local/mysql/bin/mysqld_safe
mysqladmin = /usr/local/mysql/bin/mysqladmin
log  =   /my/multi/general_log.log

[mysqld2]
socket     = /tmp/mysql.sock2
port       = 3307
pid-file   = /usr/local/mysql/data2/hostname.pid2
datadir    = /usr/local/mysql/data2
log  =   /my/multi/log2.log

[mysqld3]
socket     = /tmp/mysql.sock3
port       = 3308
pid-file   = /usr/local/mysql/data3/hostname.pid3
datadir    = /usr/local/mysql/data3
log  =   /my/multi/log3.log
root-/my/multi# dir
total 16
drwxr-xr-x   2 mysql root  4096 Feb 18 17:49 ./
drwxr-xr-x  16 jorge jorge 4096 Feb 18 17:48 ../
-rw-rw----   1 mysql mysql  489 Feb 18 17:51 log2.log
-rw-rw----   1 mysql mysql  489 Feb 18 17:51 log3.log
root-/my/multi#
[23 Feb 2005 3:01] Jim Winstead
This is already fixed in the MySQL 4.1 series (either in 4.1.6 or 4.1.7).