Bug #71426 MySql for Excel is installed but isn't loaded, In fact I don't see the button
Submitted: 20 Jan 2014 15:08 Modified: 22 Jan 2014 17:49
Reporter: luca zuppiroli Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:1.1.3 OS:Microsoft Windows (Win 7 SP2)
Assigned to: CPU Architecture:Any
Tags: MySQL for Excel

[20 Jan 2014 15:08] luca zuppiroli
Description:
Installed the plug in MySql for Excel, after a first fail (ask for the .NET runtime). Installed the .NET runtime and restart the installation of the plug in.
At the restart of Excel, in the DATA bar, I can't see the Icon of MySql. 
I've check in the registry and in option->add-on menu in Excel, the add on is there... If I try to load it.. (from the menu on the bottom) the popup window show to me the plug in I try to check the box and confirm... But nothing happen.. 
Of course I've on the same machine installed the MySql server. 

Environment: 
Office 2007
MySql server 5.6

How to repeat:
Reaaly no idea. Isn't the fist time I install that. And always work.
[20 Jan 2014 16:38] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70994 marked as duplicate of this one.
[20 Jan 2014 19:31] luca zuppiroli
You do not have access to bug #70994.
[21 Jan 2014 6:05] Javier Treviño
Can you please share more details about the installation?
I could not reproduce the problem following the steps you described.
Some details that would be helpful:

Office version and bitness.
VSTO version and bitness.
Windows version and bitness.
Windows registry path where MySQL for Excel got installed.
Windows registry path where VSTO got installed.
User that installed it was an administrator?
Was the MySQL for Excel a new installation or an upgrade from a previous version?

Thanks.
[21 Jan 2014 8:41] luca zuppiroli
Still I don't understand why I cant access to this link..
http://bugs.mysql.com/bug.php?id=70994
Anyway
Office version 12.0.6425.1000
VSTO version 10.0.40219.325
Win 7 pro 6.1.7601 SP1 build 7601
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\MySQLForExcel
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio

All was installed from the administrator account.
MySQL for excel was a NEW installation from MySQL installer. 
Visual Studio is installed from a fresh download. (monday) 
MySQL was installed last week

Thanks for your help 
Luca
[22 Jan 2014 10:01] luca zuppiroli
Some information more. 
All the time I launch Excel, the key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\MySQLForExcel\LoadBehavior 

is set from 3 or 2, as I write, to zero. 

I've check the antivirus status (disabled) 

Fallowing this help 
http://blogs.msdn.com/b/vsod/archive/2008/04/22/troubleshooting-com-add-in-load-failures.a...

I've see also i don't have the Addins in

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel

that is normal ? 

I'm running as administrator. 

If I go on Excel on the Add in menu, I see my add in there, I choose add in COM, and I launch that, I see the add on available, unchecked. In the lower side of the dialog box, I see the behavior at start up: not loaded. 

if I check the box and I press "OK" nothing happen. 

Really frustrated. 

Thanks for any help
[22 Jan 2014 17:44] Javier Treviño
It is correct the add-in is not installed under the HKEY_CURRENT_USER registry node, it must be installed under the HKEY_LOCAL_MACHINE one for the add-in to be accessible by all users.

I found the reason of your problems, will add another comment with all that information.
[22 Jan 2014 17:49] Javier Treviño
The problem is caused by a reported issue with Office 2007 and COM Add-Ins, a Hotfix from Microsoft is needed, that hotfix is installed also by Windows Update so if you are seeing the issue it means your computer does not have all updates from Microsoft applied.

After the updates are installed or the hotfix is applied the Add-In works fine.

Here is the Microsoft article that explains what I mentioned above:
http://support.microsoft.com/kb/976811/en-us
[20 Oct 2015 12:25] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=78419 marked as duplicate of this one.
[10 May 2016 6:55] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=81357 marked as duplicate of this one.