Bug #71331 bug in mysqlcheck when dot contained in table name
Submitted: 9 Jan 2014 15:43 Modified: 21 Mar 2014 5:27
Reporter: xiaobin lin (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.1+ OS:Any
Assigned to: CPU Architecture:Any
Tags: dot, mysqlcheck, tablename

[9 Jan 2014 15:43] xiaobin lin
Description:
error occurs when table name contains dot

How to repeat:
create table `t.1`(a int) engine=myisam;
--exec $MYSQL_CHECK --databases test -a
drop table `t.1`;

Suggested fix:
as in patch, confirm that all table names passed to handle_request_for_tables() are table_name only, do not contain dbname
[9 Jan 2014 15:45] xiaobin lin
based on 5.6.13

(*) I confirm the code being submitted is offered under the terms of the OCA, and that I am authorized to contribute it.

Contribution: bugfix_mysqlcheck.5613.diff (application/octet-stream, text), 2.97 KiB.

[10 Jan 2014 4:53] Umesh Shastry
Hello Xiaobin,

Thank you for the report and contribution.
Verified as described.

Thanks,
Umesh
[17 Mar 2014 5:59] Erlend Dahl
This is a duplicate of 

 Bug#68015 mysqlcheck handles table names with dots incorrectly

which has been fixed in the upcoming 5.6.17 and 5.7.4.
[20 Mar 2014 18:06] xiaobin lin
add a bugfix suggestion
[20 Mar 2014 18:07] xiaobin lin
based on 5.5.18

(*) I confirm the code being submitted is offered under the terms of the OCA, and that I am authorized to contribute it.

Contribution: bug69574.diff (application/octet-stream, text), 2.55 KiB.

[21 Mar 2014 5:27] xiaobin lin
sorry, the last two comments should be ignored. (They are about another bug)
[24 Mar 2014 14:03] Ståle Deraas
Hi Xiaobin Lin,

From the comments above, I assume you have concluded that your contributions were not used. We anyway want to thank you for your contributions.

Staale