Bug #71255 Workbench hangs nearly exery time I exit the tool
Submitted: 30 Dec 2013 20:02 Modified: 21 Jul 2014 12:44
Reporter: Paul Coene Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.38 OS:Linux (Ubuntu 12.04)
Assigned to: CPU Architecture:Any
Tags: exit hang workbench

[30 Dec 2013 20:02] Paul Coene
Nearly everytime I exit workbench it hangs.  Often I am forced to kill the process.  I can even simply open a db connection and then try to exit.

How to repeat:
Open workbench.  Open a few query tabs, including at least one function call in a tab.  Try and exit.

The above is my common use case, but I can even just open workbench, open my db connection and then try to exit.  Even that hangs often.
[7 Jan 2014 15:53] Alfredo Kojima
Please try version 6.0.8
[7 Jan 2014 18:07] Paul Coene
Is there an easy prepackaged way for Ubuntu 13.04?  Ubuntu thinks I have the latest.
[8 Jan 2014 0:25] Paul Coene
Ah I remember now.  I tried upgrading and I got:

meownan@EQEMU-SERVER:~/Downloads$ sudo dpkg -i mysql-workbench-community-6.0.8-1ubu1204-amd64.deb  
(Reading database ... 504215 files and directories currently installed.)
Unpacking mysql-workbench-community (from mysql-workbench-community-6.0.8-1ubu1204-amd64.deb) ...
dpkg: error processing mysql-workbench-community-6.0.8-1ubu1204-amd64.deb (--install):
 trying to overwrite '/usr/lib/mysql-workbench/libwbpublic.so', which is also in package mysql-workbench 5.2.38+dfsg-3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:

Im guessing that the existing stuff is ubuntu's prepackaged stuff?
[8 Jan 2014 19:59] Alfredo Kojima
Try the official download site at http://dev.mysql.com/downloads/tools/workbench/
[8 Jan 2014 20:38] Paul Coene
Yes, thats what I tried to install from when I got those messages.

I am guessing that that release won't install on top of what I have?  I'm loathe to remove all my packages..  is that what I have to do.

The output I pasted there (above) is what I get when trying to install the release form the official site.
[9 Jan 2014 1:10] Alfredo Kojima
The package you tried to install if for Ubuntu 12.04, but you say you have 13.04? Anyway, the error you got installing is because you have another very old version installed. Just do an apt-get remove mysql-workbench  first and you should be fine.
[9 Jan 2014 13:28] Paul Coene
The 13.04 was my mistake.  I have 12.04.

I'll try removing the old one.  I'm pretty sure its fine, but I want to ask anyway - all my mysql data will be safe?
[9 Jan 2014 13:31] Alfredo Kojima
Yes, removing Workbench will leave both your MySQL and Workbench data and configs untouched.
[11 Jan 2014 19:26] Paul Coene
Installed - I'll let you know how it goes.
[12 Feb 2014 14:00] Alfredo Kojima
Please try version 6.1
[1 Mar 2014 22:15] Paul Coene
This works fine now in the latest version/
[21 Jul 2014 12:44] MySQL Verification Team
Thank you for the feedback.