Bug #71226 Cannot unistall MySql for Visual Studio 1.0.2
Submitted: 25 Dec 2013 3:45 Modified: 23 Oct 2015 1:00
Reporter: RAMIRO BATALLAS Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S1 (Critical)
Version:1.0.2 OS:Microsoft Windows (Windows 7 x64)
Assigned to: Luis Penunuri CPU Architecture:Any
Tags: 64, visualstudio, win, win7, WinX64, x64

[25 Dec 2013 3:45] RAMIRO BATALLAS
Description:
I'm trying to uninstall it, but in the process's middle, the operation performs a rollback and i don't know why.

How to repeat:
go to control panel ---> Program and Features ---> Choose MySql Connector Net 6.7.4 ---> Uninstall it
[6 Jan 2014 17:02] Gabriela Martinez Sanchez
Hi Ramiro,
I'm confused. Are you trying to uninstall MySQL for Visual Studio or Connector/Net 6.7?
[6 Jan 2014 17:39] RAMIRO BATALLAS
Hi 

I'm trying uninstall both of them and i can't
[6 Jan 2014 20:59] Gabriela Martinez Sanchez
Hi Ramiro,
If you used the MySQL Windows Installer you can run the msi of each product individually. We can run the uninstalling action with the verbose log so we can have more accurate information about what the problem is.

Please do the following:
From a cmd prompt window go to this path:

C:\ProgramData\MySQL\MySQL Installer\Product Cache

You should see the connector/net msi and the visual studio plugin too.

To uninstall:

msiexec -x MySql.VisualStudio.Plugin.msi /lvx* c:\logrepair.txt

So the last parameter is the path where the log will be created.

After that you can upload the log so we can see what is preventing the uninstalling to be completed.
[11 Jan 2014 23:35] RAMIRO BATALLAS
logrepair_mysql-connector-net-6.7.4

Attachment: logrepair_mysql-connector-net-6.7.4.txt (text/plain), 379.06 KiB.

[11 Jan 2014 23:36] RAMIRO BATALLAS
logrepair_mysql-visualstudio-plugin-1.0.2

Attachment: logrepair_mysql-visualstudio-plugin-1.0.2.txt (text/plain), 524.91 KiB.

[13 Jan 2014 15:28] Gabriela Martinez Sanchez
hi Ramiro, 
Thanks for posting the log. There's an error related to a missing file:

CAQuietExec:  System.IO.FileNotFoundException: Could not load file or assembly 'file:///C:\Program Files (x86)\MySQL\MySQL for Visual Studio 1.0.2\Assemblies\v2.0\MySql.Data.dll' or one of its dependencies. The system cannot find the file specified..

Have you tried making a repair of the installation and then trying to uninstalling again? (the repair will put the missed file so then you can uninstall the product).
[14 Feb 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 Feb 2014 1:13] RAMIRO BATALLAS
Hi, 

I tried to repair the installation but does not work, i don't know what can i do?, because i was thinking in reinstall windows just for fixing this bug.

what else can i do?

thanks for your kind help
[28 Aug 2014 17:13] Gabriela Martinez Sanchez
Hi Ramiro,

We have a standalone new msi for this product. If you  like to try the installation with the new one. Possibly that solve the problem.

You can download it here:
http://dev.mysql.com/downloads/windows/visualstudio/

Please let us know if that works for you.

Thanks!
[29 Sep 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[29 Sep 2014 3:13] RAMIRO BATALLAS
not works.. has the same problem
[8 Oct 2014 18:42] Ivan Zhekov
I have the same issue. Not I have uninstalled VS 2012 and VS 2012 through the time, but I can see the package depends on these which may be the actual reason the uninstaller to fail.

Updating the package doesn't work as well.
[21 Oct 2014 10:37] Dheeraj Kumar
I am having same issue , i am trying to remove it but each time it just rollsback and nothing happens ..

please help as i need to upgrade 

thanx
[28 May 2015 20:32] Lorenzo Canapicchi
Have exactly the same problem, anyone got a way to fix it?
[28 May 2015 20:38] Lorenzo Canapicchi
1: Removing files
1: Unregistering help collection
1: Unregistering provider
1: Removing shortcuts
1: Removing system registry values
1: UnregisterPerfCounterData
1: RollbackUnregisterPerfCounterData
1: Unpublishing Product Features
1: Updating component registration
1: InstallInitialize
1: 1: MySQL for Visual Studio 1.1.1 2: {365192B1-6B3B-4EF8-BAD4-3E238CFEDF32} 3: 3 
1: The action 'Remove' for product 'MySQL for Visual Studio 1.1.1' failed.

I also tried to install again but it says the same versione is installed so I'm stuck, no install and no uninstall...
[12 Aug 2015 15:26] Esteban Filardi
I'm having the same problem except that I'm using version 1.2.4. I think the problem is that I uninstalled first Visual Studio and then tried to uninstall the plugin.
[20 Oct 2015 21:10] Luis Penunuri
Fixed the bug with the M4VS installer where having any version installed on
any Visual Studio version, and then uninstall Visual Studio first, the M4VS
plugin couldn't be uninstalled or upgraded.
[23 Oct 2015 1:00] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL for Visual Studio 1.2.5 release, and here's the changelog entry:

The Installer could not uninstall m4vs if Visual Studio was uninstalled
first.

Thank you for the bug report.