Bug #71119 Workbench crashes and quits after first application load
Submitted: 9 Dec 2013 11:07 Modified: 9 Jan 2014 17:52
Reporter: Richard Buckner Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.0.8 OS:Mac OS X (10.8.5)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D1 (Critical)

[9 Dec 2013 11:07] Richard Buckner
Description:
Workbench freezes for a second or two and then quits.

I'll attach the crash report as it's too long to place into here.

How to repeat:
Open the application, connect to a remote server via a SSH tunnel, double click a database, right click and choose to select 1000 records, workbench freezes for a second or two and then quits.

I can also get it to crash if I open it and try to restore a database, it open the Finder window which rapidly fades out as it crashes and quits.

This is, visibly, the same behaviour as in the previous version and has been happening on my machine for months. I didn't report it previously because it meant creating an Oracle identity.

It's worth noting that if I re-open workbench and do the same thing it doesn't crash.
[9 Dec 2013 11:43] Miguel Solorzano
Thank you for the bug report. Verified on OS X 10.9.
[7 Jan 2014 12:26] Alfredo Kojima
Do you have some sort of Finder enhancer installed?
[7 Jan 2014 12:36] Alfredo Kojima
The crash verified by Miguel is not this one.

The crash reported seems to be similar to this issue: http://www.cocoabuilder.com/archive/cocoa/307748-crash-using-nsopenpanel-tfsvolumeinfo-get...

where someone mentions some outdated SCFinderPlugin installed being the cause. I see the same lib in your crashlog, so I would suggest uninstalling that or upgrading it.
[9 Jan 2014 17:52] Richard Buckner
I removed the SCToolbarButton and Workbench has not crashed since then. Thanks for the response.