Bug #71052 Fabric command does not display any command on Windows with msi install
Submitted: 2 Dec 2013 18:38 Modified: 19 Dec 2013 11:41
Reporter: Jose Israel Gomez Delgado Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Fabric Severity:S3 (Non-critical)
Version:MySQL Utilities 1.4.0 Labs Fabric OS:Microsoft Windows
Assigned to: Assigned Account CPU Architecture:Any
Tags: MySQL Fabric Windows

[2 Dec 2013 18:38] Jose Israel Gomez Delgado
Description:
Fabric command does not display any command...

C:\Program Files (x86)\MySQL\MySQL Utilities>mysqlfabric list-commands
Usage: %fabric <group> <cmd> [<option> ...] arg ...

mysqlfabric: error: Command (manage list-commands) was not found. 

How to repeat:
Install MySQL Utilities 1.4.0 Labs Fabric,
run mysqlfabric list-commands

Suggested fix:
The problems comes when freezing the Python code, the variable __file__ is not initialized as in the case when running the code from an interpreter.
[3 Dec 2013 5:57] Umesh Shastry
Hello Jose,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[19 Dec 2013 11:41] Mats Kindahl
Duplicate of BUG#71126