Bug #7103 mysql 5.0.2 mysqld crashes on describe any_table;
Submitted: 8 Dec 2004 12:58 Modified: 8 Dec 2004 13:09
Reporter: Brad Cooper Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.2 OS:Microsoft Windows (Windows 98 SE)
Assigned to: CPU Architecture:Any

[8 Dec 2004 12:58] Brad Cooper
Description:
Hi,

I cannot get to first base with mysql 5.0.2 

I downloaded Windows (x86)  5.0.2-alpha 37.0M and ran MD5 to check for a signature match. The install I did was one in which I chose ALL defaults. The OS is Windows 98 SE.

The problem is highly reproducible as follows:

Start mysqld

Start mysql   and type ...

mysql> use mysql;                (use the database that comes with mysql)
mysql> show tables;
mysql> describe user;          (or describe any other table)

At this point I get...

Mysqld - This program has performed an illegal operation and will be shut down.

I have been using mysql 4.1.7 under Windows 98 SE with perfect performance. After mysql 5.0.2 failed, I did a clean install of Windows 98 SE with no other applications and then mysql 5.0.2, but the problem remains the same.

I particularly wish to use 5.0.2 because it supports views.

I cannot find a reference to this in bugs at the mysql web site.
Any suggestions most welcome. Thank you for your time.

Cheers,
Brad

How to repeat:
Start mysqld

Start mysql   and type ...

mysql> use mysql;                (use the database that comes with mysql)
mysql> show tables;
mysql> describe user;          (or describe any other table)

At this point I get...

Mysqld - This program has performed an illegal operation and will be shut down.
[8 Dec 2004 13:09] Victoria Reznichenko
Duplicate for #6950