Bug #71022 mysqldbcompare fails check on same view on different schema name
Submitted: 27 Nov 2013 8:36 Modified: 21 May 2014 4:22
Reporter: Marco S. Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Utilities Severity:S3 (Non-critical)
Version:1.3.5 OS:Microsoft Windows (WIN7)
Assigned to: CPU Architecture:Any
Tags: mysqldbcompare, Views

[27 Nov 2013 8:36] Marco S.
Description:
If I have schema1 and schema2 with the same structures and definitions, mysqldbcompare fails check on views.
Indeed when I create a view without specifying the schema-name near the table in FROM clause, I see it's stored in the information schema (table VIEWS) WITH the schema name.

How to repeat:
On schema1: "CREATE VIEW a AS SELECT * FROM users" becomes
aa) "CREATE VIEW a AS SELECT * FROM schema1.users"
in the information_schema.

AND On schema2: "CREATE VIEW a AS SELECT * FROM users" becomes
bb) "CREATE VIEW a AS SELECT * FROM schema2.users"
in the information_schema.

mysqldbcompare checks aa) with bb) and fails..

Suggested fix:
- Add option to ignore views check
- Add option to ignore schema-name in views definition check
[27 Nov 2013 11:22] Umesh Shastry
Hello Marco,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[12 May 2014 14:35] Chuck Bell
Cannot reproduce. Regression test added to release-1.4.3.
[21 May 2014 4:22] Philip Olson
Fixed as of the upcoming MySQL Utilities 1.4.3 release, and here's the changelog entry:

"mysqldbcompare" failed to properly compare the same views on different
schemas. This caused the objects to be seen differently.

Thank you for the bug report.