Bug #70900 No MySQL56 Windows service in service list since upgrade to Win8.1
Submitted: 13 Nov 2013 16:53 Modified: 14 Nov 2013 17:04
Reporter: Rémi Heymann Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server Severity:S2 (Serious)
Version: OS:Windows (8.1)
Assigned to: CPU Architecture:Any
Tags: no mysqld, no windows service, windows 8.1

[13 Nov 2013 16:53] Rémi Heymann

I have installed MySQL on Windows 8 and have been using it as a database for some time as a development environment. Since I installed the Windows 8.1 upgrade, I cannot find the MySQL56 Windows service in the windows service list. I was used to start this service when I wanted the MySQL server to be running as I opted for not letting it start automatically at windows start up.

So as you can imagine, if I can’t start the service, I can’t connect to the database, the workbench can’t connect to the database and my applications can’t connect to the database.

I tried uninstalling and reinstalling the MySQL program with no better success.
In case it has something to do with the Windows 8.1 version of my Country: I live in France near Paris and use a French keyboard. 

Thank you for your reply,


How to repeat:
Upgrade to Windows 8.1 when MySQL already installed.
[14 Nov 2013 9:06] Peter Laursen
Can('t) you start the service with the "net start <servicename>" (example: "net start mysql56") command from command line? If not what error is returned? "sevice does not exist" or something else?

First step must be to figure if service is installed (but hidden for some reason) or if it is not installed properly.

(not a MySQL/Oracle person)
[14 Nov 2013 9:09] Peter Laursen
One more thing you could check: does Control Panel .. Programs list "MySQL 5.6" as installed? If it does you could try to install MySQL again using "repair" option.
[14 Nov 2013 15:06] MySQL Verification Team
Thank you for the bug report. I upgraded Windows 8 to 8.1 without to lose the
MySQL Service, please execute the below command:

c:\>sc qc mysql56
[SC] QueryServiceConfig SUCCESS

        TYPE               : 10  WIN32_OWN_PROCESS
        START_TYPE         : 2   AUTO_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : "C:/Program Files/MySQL/MySQL Server 5.6/bin\mysqld" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.6\my.ini" MySQL56
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : MySQL56
        DEPENDENCIES       :

[14 Nov 2013 17:04] Rémi Heymann
Thank you for your help Peter. My MySQL server is now running, functional and my programs can modify data in the databases.

This is what I did:

I had already tried uninstalling, reinstalling and using the repair button in the MySQL installer tool.

So after seeing your comment, I thought it would be a good idea to try using the programs list to repair MySQL as you had wrote.

First I tried using the right click repair option of the MySQL server program. This wasn’t enough.

So I decided to right click uninstall all the MySQL programs of the program list. I then reinstalled MySQL with a different installation path as some directories hadn’t been removed in the uninstall process I used. I did quite a few other manipulations. But I believe it is the right click uninstall of all the MySQL programs that triggered the success. Because, after reinstallation, I had a windows MySQL56 service in the windows service list.

So Peter’s comment helped me.

As for Godofredo miguel Solorzano, your comment may have helped me if I had seen it before trying all this. Now that everything is working, I will not try your command. But your command may be of use to somebody else that has the same problem. This command may save the fuss of having to uninstall everything and reinstall everything.

If you can’t repeat, the problem may be specific to the French upgrade from Windows 8 to Windows 8.1 when MySQL already installed.

Thank you to you both for these comments,