Bug #70866 sql/rpl_slave.cc
Submitted: 9 Nov 2013 20:16 Modified: 15 Jan 2014 9:56
Reporter: 徹 赤松 Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.6.14 OS:Any
Assigned to: CPU Architecture:Any
Tags: lineno-2886, lineno-2888, sql/rep_slave.cc

[9 Nov 2013 20:16] 徹 赤松
Description:
[root@kvmtest1 mysql-5.6.14]# cat -n sql/rpl_slave.cc|grep 288[5-8]
  2885      // Master_Ssl_Crl
  2886      protocol->store(mi->ssl_ca, &my_charset_bin); //bug
  2887      // Master_Ssl_Crlpath
  2888      protocol->store(mi->ssl_capath, &my_charset_bin); //bug

How to repeat:
[root@kvmtest1 mysql-5.6.14]# cat -n sql/rpl_slave.cc|grep 288[5-8]
  2885      // Master_Ssl_Crl
  2886      protocol->store(mi->ssl_ca, &my_charset_bin); //bug
  2887      // Master_Ssl_Crlpath
  2888      protocol->store(mi->ssl_capath, &my_charset_bin); //bug

Suggested fix:
[root@kvmtest1 mysql-5.6.14]# cat -n sql/rpl_slave.cc|grep 288[5-8]
  2885      // Master_Ssl_Crl
  2886      protocol->store(mi->ssl_ca, &my_charset_bin);  //bug
  2887      // Master_Ssl_Crlpath
  2888      protocol->store(mi->ssl_capath, &my_charset_bin);  //bug

2886 is not mi->ssl_ca, good mi->ssl_crl

2888 is not mi->ssl_capath, good mi->ssl_crlpath
[11 Nov 2013 7:00] Umesh Shastry
Hello,

Thank you for the report.
Verified as described.

Thanks,
Umesh
[15 Jan 2014 9:56] Jon Stephens
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html

Documented fix in the MySQL 5.6.17 and 5.7.4 changelogs, as follows:

        SHOW SLAVE STATUS used incorrect values when reporting
        MASTER_SSL_CRL and MASTER_SSL_CRLPATH.

Closed.
[25 Feb 2014 5:41] Neeraj Bisht
Bug#69977, is duplicate of this bug
[29 Mar 2014 18:10] Laurynas Biveinis
5.6$ bzr log -r 5750 -n0
------------------------------------------------------------
revno: 5750 [merge]
committer: Luis Soares <luis.soares@oracle.com>
branch nick: mysql-5.6
timestamp: Mon 2014-01-13 22:34:52 +0000
message:
  BUG#17772911
  
  Automerged with latest mysql-5.6.
    ------------------------------------------------------------
    revno: 5740.1.1
    committer: Luis Soares <luis.soares@oracle.com>
    branch nick: mysql-5.6
    timestamp: Fri 2014-01-10 10:17:24 +0000
    message:
      BUG#17772911: SHOW SLAVE STATUS DISPLAYS WRONG VALUES FOR SSL_CRL FIELDS
      
      SHOW SLAVE STATUS would not report the correct values for
      MASTER_SSL_CRL and MASTER_SSL_CRLPATH. It was picking the values to
      show from the wrong place (mi->ssl_ca instead of mi->ssl_crl and
      mi->ssl_capath instead of mi->ssl_crlpath).
      
      This patch fixes that and deploys a minimal test case to validate
      that the correct values are displyed on SHOW SLAVE STATUS.