Bug #70771 Several errors when trying to install the cluster on Windows
Submitted: 30 Oct 2013 11:17 Modified: 22 Dec 2017 10:01
Reporter: Maciej Maczynski Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Cluster: Configurator Severity:S3 (Non-critical)
Version:7.3.2 OS:Microsoft Windows (Server 2003, Windows 7)
Assigned to: MySQL Verification Team CPU Architecture:Any

[30 Oct 2013 11:17] Maciej Maczynski
Description:
I'm simply unable to install MySQL Cluster on Windows machine.
The installation process has many flaws.
Installation docs does not state which ssh server to use on Windows. I tried freesshd and Bitvise ssh server - no success.

First: I want to use user/password SSH authentication. When I specify windows node IP address BEFORE user/password, installer is unable to get defaults when clicking "Next".

When I finally got through, installer reports directory creation errors for "C:\Documents and Settings..." and so on. I overworked it by changing "C:\" to
"/C/" and replacing "\" to "/" in all paths. This is what bitvise server likes. Others probably can work with windows-like paths. This is why installation docs should definitely specify WHICH server to use.

Finally, installer was able to put files on server, but I got stuck on the following error:

Unable to append file /C/Program Files/MySQL/MySQL Cluster 7.3/share/mysql_system_tables.sql to /C/Documents and Settings/Administrator/MySQL_Cluster/55/tmp/install.sql on host 192.168.205.52: 'closing' object has no attribute 'close'.

How to repeat:
Just try to install MySQL Cluster 7.3 on Windows using Bitvise SSH server or freesshd server.

Suggested fix:
At least, please specify with which Windows SSH server installer is proved to work.
[30 Oct 2013 11:19] Maciej Maczynski
The exact version is 7.3.2
[30 Oct 2013 11:25] Maciej Maczynski
I also tried to install node on Windows 7 - same result.
I mean, "Unable to create directory" errors during deploy.
The user I used to connect to Windows has definitely enough permissions to create directories (I tried manually with sftp and ssh).
[6 Jan 2014 18:27] Mauricio Rocha
Got same problem on Windows Server 2008 R2. Anyone found out how to solve these errors?
[31 Mar 2014 6:33] Brandon Jackson
I'm glad i'm not the only one having these issues.

Having multiple similar issues trying to install and configure MySQL Cluster 7.3.4 on Windows 2012 R2 running freesshd 

One error I got was Failed to append file.. and right now I cant think of the two names of the files, already uninstalled everything for tonight so I can try again tomorrow.

Hope someone has some suggestions.
[21 Oct 2014 8:58] Nesreen Adly
I have the same problem but I can make every thing successfully using MobaSSH server
but it also filed when I tried to connect sql node on the other host
I also use windows 8.1
[16 Oct 2015 13:53] JOHN SARNOWSKI
Can you give manual install instructions to install the cluster the MCI does NOT WORK on windows.  see the comments above.
[16 Oct 2015 14:43] JOHN SARNOWSKI
http://dev.mysql.com/doc/refman/5.6/en/mysql-cluster-install-windows-binary.html  for install w/o mci
[22 Dec 2017 10:01] MySQL Verification Team
Hi,

Windows OS is not capable of such operations out of the box so I personally wonder why our team ever bothered but.. 

As is already answered, to do manual install (best option IMHO)
http://dev.mysql.com/doc/refman/5.6/en/mysql-cluster-install-windows-binary.html

If you want to go the "remote" path then you need to find a proper ssh server for windows that will work and according to it make key based auth work or use user/password. I see that MobaSSH is reported to work (few posts above), and last time I tried OpenSSH (http://sshwindows.sourceforge.net/) that worked too.

kind regards
Bogdan