Bug #70760 Install and Run Issue for Workbench 6.0 CE
Submitted: 29 Oct 2013 2:32 Modified: 5 Jan 2014 19:38
Reporter: Ben Rosales Email Updates:
Status: No Feedback Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.0 CE OS:Windows (2008 R2 x64)
Assigned to: CPU Architecture:Any
Tags: Microsoft Visual C++ 2010 Redistributable Package, msvcr100.dll, workbench

[29 Oct 2013 2:32] Ben Rosales
Problem documented and work around identified:

Installed MySQL system on a brand new Windows 2008 x64 Server ( with all latest OS patches) using MySQL installer (fresh download) from MySQL site.  During install received dialog (popup) notification:

 "python.exe system error 
  The program can't start because msvcr100.dll is missing from your 
  computer ...".  

Again, I note this was a clean server and this was the "first" software to be installed.  No other Microsoft development products were installed, like Visual Studio, or MS office Products.

How to repeat:
After installation finished, tried to start Workbench, but it would not open and gave no other error messages.  Cursor just spun a bit then stopped.

Tried re-installing  "Microsoft Visual C++ 2010 Redistributable Package (x64)" as implied by many other posts.  I used the x64 version of the pkg since server is x64 machine.  Tried uninstalling and re-installing Workbench with meticulous reboots to ensure clean install.  But, there was no change in results... spinning cursor and no error msgs.

After installing "Microsoft Visual C++ 2010 Redistributable Package (x64)"  the MySQL installer did not make any further indications about needing this package.

Suggested fix:
Resolution: Finally found a post about older version of Workbench with similar issue.  It was resolved by installing "Microsoft Visual C++ 2010 Redistributable Package (x86)".  Note this is the x86 version.  Workbench began to function immediately without reboot.  Problem was resolved for me.

So at the end I actually had both versions of this pkg installed on my server.
[5 Dec 2013 19:38] Alfredo Kojima

WB is a 32bit app currently, so you need to install the 32bit version of the MSVC redistributables.
[6 Jan 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".