Bug #70623 Can't submit a feed to planet.mysql.com
Submitted: 15 Oct 2013 13:15 Modified: 24 Nov 2015 13:29
Reporter: Art van Scheppingen Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Websites: bugs.mysql.com Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[15 Oct 2013 13:15] Art van Scheppingen
Description:
Sorry for placing it under bugs.mysql.com but there simply is no way to submit a bug for planet.mysql.com. ;)

I tried adding the Spil Games Engineering blog feed several times to the planet.mysql.com feed adder (http://planet.mysql.com/new) but all I receive is this error:
Unable to read feed 'http://engineering.spilgames.com/feed/': A feed could not be found at http://engineering.spilgames.com/feed/
This could mean either the feed is not giving any output at all or it is not a valid feed. 

I already used the feedback form twice but have not received a reply so far. This sounds reasonable as the feedback form actually is a frontend for Oracle sales. ;)

I did validate the feed through feedvalidator.org (as suggested) which validates it perfectly fine. I also tried to curl the output and that also works.

How to repeat:
Go to planet.mysql.com and log in, then add a new feed and add this feed url: http://engineering.spilgames.com/feed/

To double check you can also see the feed exists and gives output:
curl -i http://engineering.spilgames.com/feed/

Suggested fix:
1. Add planet.mysql.com to the bug categories
2. Add better description/help on the add feed page where to direct questions to
3. Find out why the feed submission is not working.
[15 Oct 2013 14:04] Morgan Tocker
Verified as described
[24 Nov 2015 13:29] Morgan Tocker
Art and I found a workaround by using Feedburner as an intermediate.  The underlying cause was not found, but there is a viable workaround in place.

Changing to 'Won't fix'.  Will investigate more if there are subsequent reports.