Bug #70616 planet.mysql.com removing posts
Submitted: 14 Oct 2013 18:52 Modified: 5 Nov 2013 18:38
Reporter: Marcelo Altmann Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Websites Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[14 Oct 2013 18:52] Marcelo Altmann
Description:
I write posts in 2 languages English (blog.marceloaltmann.com) and pt-br (pt.marceloaltmann.com).
I've both feeds (blog.marceloaltmann.com/feed/ and pt.blog.marceloaltmann.com/feed/) submitted on each planet.mysql.com website.
When pt.planet.mysql.com fetch the pt-br version of my posts, it add my posts to pt.planet.mysql.com, but when the english version of the site fetch the english version of feed, it remove it from pt.planet.mysql.com and add just the english version on planet.mysql.com

How to repeat:
Add 2 different feeds from the same root website in 2 planet.mysql.com website(different language).
Monitor both websites, when language 1 website had its feed fetched it will index all posts in the assigned planet.mysql.com website, when langague 2 website got fetched by a different planet.mysql.com language website, this will remove the indexed posts from the other language
[5 Nov 2013 18:38] Sveta Smirnova
Thank you for the report.

I sent your request to our Web team. They will proceed further.
[7 Nov 2013 12:06] Sveta Smirnova
I just got the answer from the Web team:

----<q>----
This isn't something we can fix. The problem is with the feed. Blog feeds provide a unique ID for each entry, usually in the form of a permalink URL. Planet uses this GUID as a unique index, and will replace any content with the same GUID (so we can pick up updates and edits).

The problem is that this particular blog is using the same GUID for both language versions. For example, the first post in both feeds is this:

 - (en) Installing latest version of MySQL via yum
 - (pt) Instalar a versão mais recente do MySQL via yum

While the entry links are different, the GUIDS are the same:

 - (en) http://blog.marceloaltmann.com/?p=717
 - (pt) http://blog.marceloaltmann.com/?p=717

I would expect to see the GUID change for the translation, most likely to http://pt.blog.marceloaltmann.com/?p=717. Since that's not the case, Planet is (correctly) replacing the previous content so only one language is actually showing up in the aggregate.

The same issue actually exists with the blog link in the feed. the pt-br feed still links to the English blog. This user needs to straighten out their feeds.
----</q>----

So this is something on your side. Please fix it.