Bug #70585 Excel-Add-In not visible for users in Data - Quick Access Toolbar
Submitted: 10 Oct 2013 11:11 Modified: 5 Nov 2013 22:42
Reporter: Gert Jan Zeilstra Email Updates:
Status: Duplicate Impact on me:
Category:MySQL for Windows: MySQL for Excel Severity:S3 (Non-critical)
Version: OS:Windows (Windows 7 & Excel 2013)
Assigned to: Javier Treviño CPU Architecture:Any
Tags: excel 2013, Excel-Add-In, not loading, Quick Access Toolbar, windows 7

[10 Oct 2013 11:11] Gert Jan Zeilstra
Users on the target machine cannot see the Excel-Add-In on the Data Quick Access Toolbar.

System: Windows 7, 64 bit
Excel: Excel 2013
Language: Dutch

How to repeat:
MySQL, including the Excel-Add-In, are normally installed under a user account that is member of the Administrator group or the Administrator account. Users using this system are member of the standard Users group.

After installation Users, and also new users, will not see the Excel-Add-In on the Data Quick Access Toolbar for existing and for new Excel sheets. Also starting Excel with Administrator privileges will not solve the problem and adds a security risk because possible VBA and macro's get also Administrator access to the target machine.

Suggested fix:
Make the installation work properly on Windows 7 with Excel 2013 installed.

The below work-around is only tested on a single target machine running Windows 7, 64 bit with Excel 2013 with all updates and service packs installed. It was a fresh install. It may not work for everybody and is given as-is without any guarantee that it will help you. Use it carefully because deleting user accounts on a machine and their profiles will lead to loss of data. When you do not have advanced computer skills you probably do not want to do this, the solution at the bottom may be better for you. My description may contain some translation mistakes because it is a Dutch PC.

Work-around until this is fixed but do not skip steps to avoid loss of data, you can also try this by first creating a new local test account so you are sure it also works for you before taking all the steps below:
0. Backup your system and create a system restore point
1. Make a backup of the Users folder that require access to the Excel-Add-In
2. Remove the Users from the system (delete their accounts)
3. Rename their profile folder in <win-drive>:\Users\<Users>, I suggest renaming is the safest method.
4. Add Users back as Administrator and add them to the Administrator group
5. Login under the User name so that their new profile exists
6. Start Excel, you should now see the Excel-Add-In
7. Log the User out and remove them from the Administrator group, keep them part of the Users group.
8. Login as the User and start Excel again, the user now has access to the Excel-Add-In with normal User privileges.
9. Repeat this for the other Users that where removed
10. Consider parts of the original profile that must be restored but do not copy all content because that may break the fixed functionality

This worked for us. Please leave your comment here if it also works for you with details on your machine (Ssytem, Excel and Language) so that others can benefit.

Suggested changes to the Registry as suggested in bug #68746 did not work.

Suggested elevation to run as Administrator as suggested in another bug is not good practice because it adds a security risk to the system because VBS code and macros will also run with elevated privileges.

Giving users Administrator rights did not work for us. The problem would not go away.

We did see the Excel-Add-In when users get Administrator rights and you repair the MySQL For Excel 1.1.1 installation (Control Panel, Programs and Features, MySQL For Excel 1.1.1, Repair). But it would disappear when the user is removed from the Administrators group. This is not tested in depth because I do not consider giving all users local Administrator rights as a good idea.
[10 Oct 2013 11:54] Gert Jan Zeilstra
When the Excel-Add-In not visible is in step 6 of the work-around then repair the MySQL For Excel 1.1.1 installation (Control Panel, Programs and Features, MySQL For Excel 1.1.1, Repair).

Some users may try this step before doing anything else because sometimes this seems to work as well. In an existing user that I tried this didn't work but it sometimes seems to have the same effect.
[5 Nov 2013 22:42] Javier Treviño
This bug is a duplicate of bug 68746 which has already been fixed in MySQL for Excel 1.1.3.