Bug #70511 Export Data Error 2049: Connection using old (pre-4.1.1) authentication protocol
Submitted: 3 Oct 2013 16:43 Modified: 26 Aug 2015 13:16
Reporter: Frank Troglauer Jr Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:6.0.7.11205 OS:Microsoft Windows (8)
Assigned to: CPU Architecture:Any
Tags: 2049, authentication, Connection, data, error, export, old, protocol

[3 Oct 2013 16:43] Frank Troglauer Jr
Description:
Good afternoon,

I am trying to export data using MySQL Workbench. I connect to the server and then go to Data Export and select the databases. When I try to export it shows the authentication protocol error. I thought I prompted Workbench to use old authentication methods which allowed me to login to the database in the first place.

http://prntscr.com/1v0vee

How to repeat:
Connect to MySQL database that requires you to disable secure_auth off.
Attempt to export data.
[17 Oct 2013 18:02] Alfredo Kojima
Try resetting your password for your MySQL account. That error occurs because your password was created in an old version of MySQL and was never upgraded to the new format, which is more secure.
[17 Oct 2013 18:14] Frank Troglauer Jr
Unfortunately we have to use HostGator Cpanel and we have tries this with a new user so I don't think that is it.
[19 Dec 2013 22:10] Bill Antalek
I have the same problem with the Mac version downloaded 12/17/13  6.8.0
Please let me know when it's fixed.

I can get it to work if I go to phpmyadmin and clear the admin password temporarily.
[19 Dec 2013 22:36] Bill Antalek
Update: I reset the admin password with workbench and it seems to work now.
[3 Mar 2014 19:57] Alfredo Kojima
The problem is that export is done using mysqldump, which does not support forcing the use of the pre-4.1.1 authentication protocol yet. Your best hope is to reset the account password, so that the hash will be regenerated.

BTW what's the version of the server you're connecting?
[22 Sep 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[22 Sep 2014 18:04] Domenico LANZA
I'm not the administrator and the password change may impact some applications that I do not have in direct control.
How can I mysqldump forcing old password behavoir ?

Domenico
[26 Aug 2015 13:16] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=78060 already verified.