Bug #70439 SQL Result Set can no longer be edited (Invalid "read only" status)
Submitted: 26 Sep 2013 16:57 Modified: 19 Nov 2013 17:37
Reporter: Mike Reid Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.0.7 OS:Mac OS X (10.8.4)
Assigned to: CPU Architecture:Any
Tags: editor, read only, results, SQL

[26 Sep 2013 16:57] Mike Reid
Description:
Since upgrading to MySQL Workbench v6.0.7, I have noticed on a few separate occasions that the SQL Editor Result Set panel will report certain result sets as "read only" not allowing direct edits. 

I realize this is the intended behavior depending on the schema or the result set in question, but this is happening intermittently for specific results sets I work with all the time and have to problems "editing" via the Result Set panel.

The issue is that Workbench is erroneously flagging certain result sets as "read only", just not all the time. When this happens, only closing and re-opening Workbench fixes the problem. 

I can re-run the exact same SQL, and begin editing records again. Then, after a while, editing is no longer an option because of a false "read only" status.

How to repeat:
Unfortunately, I have not figured out the steps necessary to reproduce. However, this bug is so frustrating, I had to ensure I at least documented it here in case others may be experiencing this behavior and can help contribute towards finding a solution.

Suggested fix:
Ensure result sets capable of edits are always editable, and not flagged as "read only" when not necessary.
[19 Nov 2013 17:37] Mike Reid
Closing. Will evaluate 6.0.8 behavior and re-open, if necessary.