Bug #70422 ODBC 5.2.5 dmg installer fails on OSX 10.8.5
Submitted: 25 Sep 2013 20:12 Modified: 14 Feb 2014 19:16
Reporter: Brogan Beard Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.2.5/5.3.1 OS:Mac OS X (10.8.5)
Assigned to: CPU Architecture:Any
Tags: 5.2.5, install, ODBC, osx
Triage: Needs Triage: D2 (Serious)

[25 Sep 2013 20:12] Brogan Beard
Description:
The ODBC 5.2.5 installer downloads and opens normally on OSX 10.8.5.  After choosing a location to install, it begins the installation process but fails before it completes.

How to repeat:
Use Mac OSX 10.8.5(maybe just 10.8).  Try to install the ODBC 5.2.5 driver in dmg file format.

Suggested fix:
Please allow for it to install on Mac OSX 10.8.5.
[26 Sep 2013 2:06] Miguel Solorzano
message error of install failed

Attachment: install_failed.png (image/png, text), 124.77 KiB.

[26 Sep 2013 2:10] Miguel Solorzano
Thank you for the bug report.
[28 Jan 2014 17:06] Lamont Peterson
I am having the same problem on Mac OS X 10.9.1, with both the 32-bit and 64-bit DMG installs.  Also, no good "uninstall" instructions, though, I figured out which files to nuke (I think).
[29 Jan 2014 11:28] Bogdan Degtyariov
Posted by developer:
 
The problem is in the wrong configuration for ANSI/UNICODE driver
The drivers are registered as "MySQL ODBC 5.3 @CONNECTOR_DRIVER_TYPE@ Driver" instead of 
"MySQL ODBC 5.3 ANSI Driver"
"MySQL ODBC 5.3 UNICODE Driver"
[29 Jan 2014 14:47] Hamlet Javier
Thanks @Bogdan.  So if that's the problem, what's the solution?
[30 Jan 2014 11:09] Bogdan Degtyariov
Posted by developer:
 
The patch for the problem has been pushed into the working ODBC Driver source tree.
Now the DMG installer works for OSX 10.8
[30 Jan 2014 14:26] Hamlet Javier
That's great to hear @Bogdan, thanks.  So I see that http://dev.mysql.com/downloads/connector/odbc/ still has mysql-connector-odbc-5.2.6-osx10.7-x86-64bit.dmg - I take it that's the one that's  been updated to work with 10.8?
[6 Feb 2014 23:01] Akram Abouemara
I am still running into the same issue with ODBC 5.2.6 and OSX 10.9.1
[14 Feb 2014 19:13] Daniel So
Posted by developer:
 
Hi, Hamlet and Akram: According to the notes above, the fix will only be available in 5.2.7, and 5.3.2. 5.2.6 will suffer the same issue, I'm afraid.
[14 Feb 2014 19:16] Daniel So
Added the following entry into the Connector/ODBC/5.3.2 and 5.2.7 changelogs:

"The DMG installer for Connector/ODBC failed on OS X 10.8 and 10.9. This fix corrects the wrong identification for the drive type, which caused the installation problem."
[14 Feb 2014 22:13] Akram Abouemara
What is the ETA on 5.3.2 and 5.2.7?
[20 Mar 2014 20:02] Per Mildner
The same issue happens on OS X 10.7.5. Also happens in e.g. 5.3.1 beta MD5: 2365c74d49e07bd70bfe106ee416f672.

Perhaps you should remove the DMG installers from the download page since they seem completely broken.

I did the obvious change to the script "MySQL Connector ODBC 5.3.pkg/Contents/Resources/postflight" (replaced @CONNECTOR_DRIVER_TYPE@ with the two words ANSI and UNICODE). The calls to myodbc-installer -a -s ... still fails, and presumably the exit code (1) from the last of these is what makes the Installer.app think that the postinstall script failed.

Also, it looks as if the odbc drivers are (partly?) installed even though the installer reports failure. Adding a simple "exit 0" at the end of the postflight script seems to make the installation succeed.

PS. The following is what I get when I try to run the failing command manually:
bash$ sudo /usr/local/bin/myodbc-installer -a -d -n 'MySQL ODBC 5.3 ANSI Driver' -t 'Driver=/usr/local/lib/libmyodbc5a.so;' || echo "bad $?"
Success: Usage count is 0
bash$ sudo /usr/local/bin/myodbc-installer -a -s -n myodbca -t 'Driver=MySQL ODBC 5.3 ANSI Driver;SERVER=localhost;' || echo "bad $?"
[ERROR] SQLInstaller error 7: 
[ERROR] SQLInstaller error 8: 
[ERROR] Data source entry failed, remove or try again
bad 1

(dtruss makes me believe that something goes wrong in the odbcinst.ini parsing)
[25 Mar 2014 4:04] Bogdan Degtyariov
Per Mildner,

You tried the wrong version. 5.3.1 still has the bug.
Version 5.3.2 should be released soon (I cannot disclose the release dates prior to the official announcement).
[22 Nov 2016 21:56] Mounika Alla
I hit the same installation failure for mysql-connector-odbc-5.3.6-osx10.10-x86-64bit.dmg image on OSX 10.10.2. 

I used the previous version 5.2.7 to install the driver successfully