Bug #70421 MySQL Workbench Action Output doesn't auto scroll
Submitted: 25 Sep 2013 16:38 Modified: 6 Nov 2013 17:06
Reporter: Sergio Bobillier Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.0.7.11215 OS:Linux (Ubuntu 12.10)
Assigned to: CPU Architecture:Any
Tags: action output, scroll, workbench
Triage: Needs Triage: D3 (Medium)

[25 Sep 2013 16:38] Sergio Bobillier
Description:
When issuing SQL commands to the server the result of these commands appear in the "Action Output" in the output window. However when various commands are issued the "Action Output" doesn't scroll down so the output of the later commands remain hidden and you have to manually go to the output window and scroll it manually.

This is not a serious bug but is pretty annoying.

How to repeat:
Start MySQL and connect to the DBMS

Issue some commands (or repeat the same command) a couple of times or until the Action Output gets filled.

It can be any command like SHOW TABLES.

Suggested fix:
Either fix the problem to make the action output scroll automatically as commands are issued or make the output of the most recent commands appear at the top of the list.
[25 Sep 2013 16:55] Miguel Solorzano
Please try 6.0.7. I couldn't repeat on CentOS 6.4. Thanks.
[25 Sep 2013 19:37] Sergio Bobillier
Tested with 6.0.7 and the problem still occurs. If you cannot reproduce it with CentOS it might be related to ubuntu's overlay scrollbars. I currently don't have other distribution installed to test with but let me see If I can test it with Mint or Fedora in a virtual machine or something.
[26 Sep 2013 1:55] Miguel Solorzano
Thank you for the feedback. Now I was able to repeat on:

miguel@miguel-VirtualBox:~$ cat /etc/issue
Ubuntu 12.04.3 LTS \n \l
[6 Nov 2013 17:06] Philip Olson
Fixed as of MySQL Workbench 6.0.8, and here's the changelog entry:

On Linux, the "Action Output" would not auto scroll to place the latest
action (executed SQL statement) in view.

Thank you for the bug report.
[1 Jun 2015 7:17] Nehemiah Jacob
Seems the issue is back, It's occurring again. 

- MySQL Workbench build - 6.3.3.0 Build 592
- Operating System - OSX 10.10.3 (14D136)

Besides the sorting is not functional as well, The windows has headers like Time, Action, Response & Duration. Sorting doesn't work for any of these headers. If sorting work this issue can be mitigated by requesting the user to sort the 'Time' in descending order so that the latest action will be at line of sight.