Bug #70415 .ibd deletion mysql is not restarting
Submitted: 25 Sep 2013 10:29 Modified: 25 Sep 2013 16:58
Reporter: manish kumar Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.5.25 OS:Linux
Assigned to: CPU Architecture:Any

[25 Sep 2013 10:29] manish kumar
Description:
Hi,

I have one mysql instance in which 25 DBs are available but i have stopped mysql instance and deleted one .ibd file from test database. Now i am not able to start mysql instance. Can you help me how we can start this mysql instance with skip of one database. Following error is displaying on error message.

############################################################################

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
130925 06:26:35 mysqld_safe Number of processes running now: 0
130925 06:26:35 mysqld_safe mysqld restarted
130925  6:26:36 [Warning] option 'net_buffer_length': unsigned value 8388608 adjusted to 1048576
130925  6:26:36 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
130925  6:26:36 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
130925  6:26:36 [Note] Plugin 'FEDERATED' is disabled.
130925  6:26:36 InnoDB: The InnoDB memory heap is disabled
130925  6:26:36 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130925  6:26:36 InnoDB: Compressed tables use zlib 1.2.3
130925  6:26:36 InnoDB: Using Linux native AIO
130925  6:26:37 InnoDB: Initializing buffer pool, size = 5.0G
130925  6:26:37 InnoDB: Completed initialization of buffer pool
130925  6:26:37 InnoDB: highest supported file format is Barracuda.
130925  6:26:38  InnoDB: Waiting for the background threads to start
130925  6:26:39 InnoDB: 1.1.8 started; log sequence number 1523827643781
130925  6:26:39 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
130925  6:26:39 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
130925  6:26:39 [Note] Server socket created on IP: '0.0.0.0'.
130925  6:26:39 [Warning] 'user' entry 'root@lfvsfcp10163.dn.net' ignored in --skip-name-resolve mode.
130925  6:26:39 [Warning] 'proxies_priv' entry '@ root@lfvsfcp10163.dn.net' ignored in --skip-name-resolve mode.
130925  6:26:39 [Note] Event Scheduler: Loaded 0 events
130925  6:26:39 [Note] /usr/local/mysql-5.5.25/bin/mysqld: ready for connections.
Version: '5.5.25-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Server (GPL)
130925  6:26:40  InnoDB: Assertion failure in thread 140399562008320 in file btr0cur.c line 330
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
10:26:40 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=1073741824
read_buffer_size=16777216
max_used_connections=0
max_threads=500
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 17438286 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x10000000
/usr/local/mysql-5.5.25/bin/mysqld(my_print_stacktrace+0x35)[0x79d255]
/usr/local/mysql-5.5.25/bin/mysqld(handle_fatal_signal+0x403)[0x66d383]
/lib64/libpthread.so.0[0x377480f500]
/lib64/libc.so.6(gsignal+0x35)[0x37740328e5]
/lib64/libc.so.6(abort+0x175)[0x37740340c5]
/usr/local/mysql-5.5.25/bin/mysqld[0x80bdcc]
/usr/local/mysql-5.5.25/bin/mysqld[0x813d94]
/usr/local/mysql-5.5.25/bin/mysqld[0x805787]
/usr/local/mysql-5.5.25/bin/mysqld[0x8071d2]
/usr/local/mysql-5.5.25/bin/mysqld[0x80cc10]
/usr/local/mysql-5.5.25/bin/mysqld[0x80f777]
/usr/local/mysql-5.5.25/bin/mysqld[0x8b1906]
/usr/local/mysql-5.5.25/bin/mysqld[0x8b204d]
/usr/local/mysql-5.5.25/bin/mysqld[0x8a76dd]
/usr/local/mysql-5.5.25/bin/mysqld[0x7e79d5]
/usr/local/mysql-5.5.25/bin/mysqld[0x7dca68]
/lib64/libpthread.so.0[0x3774807851]
/lib64/libc.so.6(clone+0x6d)[0x37740e894d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
130925 06:26:40 mysqld_safe Number of processes running now: 0
130925 06:26:40 mysqld_safe mysqld restarted
130925  6:26:40 [Warning] option 'net_buffer_length': unsigned value 8388608 adjusted to 1048576
130925  6:26:40 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
130925  6:26:40 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
130925  6:26:41 [Note] Plugin 'FEDERATED' is disabled.
130925  6:26:41 InnoDB: The InnoDB memory heap is disabled
130925  6:26:41 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130925  6:26:41 InnoDB: Compressed tables use zlib 1.2.3
130925  6:26:41 InnoDB: Using Linux native AIO
130925  6:26:41 InnoDB: Initializing buffer pool, size = 5.0G
130925  6:26:42 InnoDB: Completed initialization of buffer pool
130925  6:26:42 InnoDB: highest supported file format is Barracuda.

############################################################################

Thanks & Regards
Manish Kumar Rai
Mob:9899856382

 

How to repeat:
Please delete one .ibd file from any mysql instance then start mysql.
[25 Sep 2013 16:58] Miguel Solorzano
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.