Bug #70380 Support Firing Triggers With Foreign Key Cascade
Submitted: 19 Sep 2013 18:03 Modified: 19 Sep 2013 19:23
Reporter: Wayne Chan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.7 OS:Any
Assigned to: CPU Architecture:Any
Tags: foreign key, trigger

[19 Sep 2013 18:03] Wayne Chan
Description:
Version 5.7 and cascading delete/update still does not fire triggers. There is no clean workaround that could achieve this functionality. I appreciate the work that the Mysql has put into this wonderful DBMS, but why not just go a little bit further to make this a complete product? I would really, really appreciate if someone can address this problem, which frankly, is a bug because this makes Mysql non-ACID compliant.

How to repeat:
Create table1. Populate with test data.
Create table2 with a foreign key pointing to table1 and an AFTER UPDATE trigger to change a column. Populate with test data.
Update table1, trigger on table2 should be fired.

Suggested fix:
Make triggers fire with foreign key cascade.
[19 Sep 2013 19:15] Miguel Solorzano
Thank you for the bug report duplicate of http://bugs.mysql.com/bug.php?id=11472 .
[19 Sep 2013 19:23] Wayne Chan
It's been 8 years, when can this be fixed?