Bug #70275 Error reading relay log event: slave SQL thread was killed
Submitted: 9 Sep 2013 3:37 Modified: 23 Mar 2018 5:52
Reporter: li ming Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:MySQL-5.5.28 OS:Linux (CentOS 6)
Assigned to: CPU Architecture:Any

[9 Sep 2013 3:37] li ming
Description:
I have scheduled a daily backup by this mysqldump on a slave.
mysqldump -u$user -p$passwd --dump-slave=2 --single-transaction -B database >backup.sql

The error log on slave:

130908 3:30:01  Error reading relay log event: slave SQL thread was killed
130908 3:30:01  Slave SQL thread initialized, starting replication in log 'mysql-bin.000049' at position 93844393, relay log './mysql-relay-bin.000037' position: 93844539
130908 3:30:01  Error reading relay log event: slave SQL thread was killed
130908 3:30:32  Slave SQL thread initialized, starting replication in log 'mysql-bin.000049' at position 93844393, relay log './mysql-relay-bin.000037' position: 93844539
130909 3:30:01  Error reading relay log event: slave SQL thread was killed
130909 3:30:01  Slave SQL thread initialized, starting replication in log 'mysql-bin.000049' at position 103115353, relay log './mysql-relay-bin.000037' position: 103115499
130909 3:30:01  Error reading relay log event: slave SQL thread was killed
130909 3:30:01  Slave SQL thread initialized, starting replication in log 'mysql-bin.000049' at position 103116696, relay log './mysql-relay-bin.000037' position: 103116842
130909 3:30:01  Error reading relay log event: slave SQL thread was killed
130909 3:30:33  Slave SQL thread initialized, starting replication in log 'mysql-bin.000049' at position 103116696, relay log './mysql-relay-bin.000037' position: 103116842

How to repeat:
When add the option '--dump-slave=2' the error occur...
[11 Sep 2013 5:10] Umesh Shastry
Hello li ming,

This is a known and documented behavior:

--dump-slave[=value] causes mysqldump to stop the slave SQL thread before the dump and restart it again after. 

Please reference http://dev.mysql.com/doc/refman/5.5/en/mysqldump.html#option_mysqldump_dump-slave

Thanks,
Umesh
[12 Oct 2013 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[8 Mar 2016 9:11] Samuel ├ůslund
This is a problem in the log message.

There is no way to see if this _ERROR_ log-message is caused by a deliberate shutdown of the slave or an actual problem.
I'm looking for a problem where a user thought the replication was not working during a regular switch and backed out to ensure data-safety. Now I can not see if this message gives information or just tells me the slave was manually turned of!