Bug #70268 Unable to start application
Submitted: 8 Sep 2013 3:31 Modified: 8 Sep 2013 22:25
Reporter: John Borden Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.0.6 OS:Windows (7)
Assigned to: CPU Architecture:Any

[8 Sep 2013 3:31] John Borden
Description:
Workbench ran great for two days after installing on Sept. 4 (really neat program, by the way), then suddenly gave me an error message when I was trying to save a script file: "Workbench has encountered a problem. External component has thrown an exception." Now it gives me the same message whenever starting the program. When I close the dialog box the program dies.

I’ve tried uninstalling and reinstalling. I finally suspected there might be a conflict between my XAMPP installation and the MySQL that came with Workbench, since I had chosen “Developer Default” in the Choose Setup screen, so the next time, after uninstalling all the MySQL components, I reinstalled only MySQL Workbench 6.0.6. Same problem came up. I restored my system to the Restore Point I had created just prior to my initial installation, then tried reinstalling it again (Workbench only). Same problem. 

During my last try, I uninstalled all the MySQL applications including Workbench, delete all the MySQL folders in Program Files, and even went into the Registry and delete all references I could find to “workbench”. Still no good – the same error comes up.

My computer is a DELL Latitude E6400 notebook, which has never given me any problems. For what it's worth, the instance of MySQL that came with XAMPP, along with the Apache server, are still working fine, and I have no problem using PHP to access my MySQL databases. 

How to repeat:
I can never NOT repeat the problem. Workbench is now useless to me.
[8 Sep 2013 8:06] Peter Laursen
The workaround from hre http://bugs.mysql.com/bug.php?id=70262 may work for you too!

It seems that when reading and using data from a 'roaming profile' WB may cause some corruption (memory corruption , heap corruption, whatever).

To find more details of the crash you should check the Windows 'event viewer' (Control Panel .. Administration .. Logs .. Applications (translated from Danish Windows)). I am not saying that what Windows logs here is very informative. But it is better than nothing.  There is an error code, for instance, identifying the problem as a heap corruption, if this is the case.

Peter
(not a MySQL/Oracle person)
[8 Sep 2013 20:37] John Borden
to: Peter Laursen

We have liftoff! That simple workaround you gave me actually worked. Thanks!

John
[8 Sep 2013 22:25] MySQL Verification Team
Thank you for the bug report and feedback. Duplicate of bug http://bugs.mysql.com/bug.php?id=70262.