Bug #70195 workbench crash after running sql query
Submitted: 30 Aug 2013 8:11 Modified: 7 Feb 2017 0:01
Reporter: Pankaj Agarwal Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.0.6 OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any
Tags: workbench crash

[30 Aug 2013 8:11] Pankaj Agarwal
Description:
I happens randomly. The workbench stops responding after running any query in the SQL Editor

How to repeat:
mentioned in the description

Suggested fix:
fix the hangs and freezes
[30 Aug 2013 12:00] Miguel Solorzano
I couldn't repeat. Please check for detail when that happens and describe more your environment (type of connection local/remote, large/small data result query, etc). Thanks.
[2 Sep 2013 5:39] Pankaj Agarwal
The connection is a remote one connecting to a remote-server. The query that I do which results in the crash varies, and the data-set returned isn't large too. One of the queries which causes the crash is 
select * from information_schema.PROCESSLIST where info is not null;
[2 Sep 2013 17:24] Alfredo Kojima
Can you send a zip of the log files from when a crash occurs? You can locate it from the Help menu
[3 Sep 2013 17:54] Miguel Solorzano
Please try version 6.0.7. Thanks.
[1 Oct 2013 9:41] Pankaj Agarwal
I'm using the 6.0.7 version but the problem still persists
[1 Oct 2013 9:42] Pankaj Agarwal
The log file for the crash

Attachment: wb.1.log (application/octet-stream, text), 11.11 KiB.

[9 Jan 2014 0:28] Alfredo Kojima
Can you try moving the files in C:\Users\YOU\AppData\Roaming\MySQL\Workbench\cache to some other directory? (please don't delete them; if they are the cause of the crash, we'd like to check what's wrong)
[6 Mar 2014 0:47] Alfredo Kojima
Please try version 6.1.2, it fixes something that might be the source of your problem.
[6 Apr 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[12 Aug 2016 17:11] Wes n/a
I'm experiencing the same issue but on a different version of the workbench and platform:

MySQL Workbench Community (GPL) for Mac OS X version 6.3.7 CE build 1199 (64 bit)
Configuration Directory: /Users/wes/Library/Application Support/MySQL/Workbench
Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
Cairo Version: 1.10.2
OS: OS X 10.11.x El Capitan
CPU: 8x Intel(R) Core(TM) i7-4980HQ CPU @ 2.80GHz - 16.00GiB RAM

What diagnostics info can I provide?
[7 Feb 2017 0:01] Miguel Solorzano
I couldn't repeat with 6.3.8. on Windows 10 Pro and Windows 7 Ultimate.