Bug #70193 Crashing when opening another model file when one is already open
Submitted: 30 Aug 2013 7:49 Modified: 4 Sep 2013 11:24
Reporter: Espen Tønnessen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:6.0.6.11184 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[30 Aug 2013 7:49] Espen Tønnessen
Description:
When I have a open model file, and then open another instead, workbench frequently crashes. Not all the time, but more often than not.

How to repeat:
Open a model, then open another. Try repeatedly.
[30 Aug 2013 13:17] Miguel Solorzano
Thank you for the bug report. Which exactly Windows version are you using? I could repeat with below one:

MySQL Workbench Community (GPL) for Windows version 6.0.6  revision 11184

Configuration Directory: C:\Users\miguel\AppData\Roaming\MySQL\Workbench

Data Directory: C:\MySQL Workbench 6.0.6 CE

Cairo Version: 1.8.8

OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit

CPU: 4x AMD Phenom(tm) 9650 Quad-Core Processor, 8.0 GiB RAM

Active video adapter ATI Radeon HD 4650

Installed video RAM: 1024 MB

Current video mode: 1920 x 1080 x 4294967296 colors

Used bit depth: 32

Driver version: 8.970.100.7000

Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

Current user language: Portuguese (Brazil)
[2 Sep 2013 11:27] Jeff Sellers
I would like to express a deep thanks to Mike Lischke and the other developers of Workbench for a great product.  They have fixed another bug I reported a year ago on Workbench Version 5 something.

However, I'm having similiar problem along with other things. I've even uninstalled MySQL Workbench Community 6.0.6.11184 Progressively getting worse.  Until this is fixed, I'll have to use 5.2 again.

Here's the problems I've been having:

1. Crashing when opening another model file when one is already open. Specific error is: "MySQL Workbench has stopped working  A problem caused the program to stop working correctly.  Windows will close the program and notify you if a solution is available."
2. Also, crashes after first opening workbench for first time and opening my saved MySQL connection across 127.0.0.1:3306
3. Can not submit a crash report within Workbench.  Keeps saying I need an account, even though I'm using my correct Oracle/MySQL account that I'm using here on bugs.mysql.com to submit this report.
4. Other crashed too, but I can't remember what they were.

Here's how to duplicate:

1. Open MySQL Workbench 6.06 (naturally)
2. Click on saved MySQL Connections on main page. In my case, I'm using Ampps stack.
3. Open a previously saved model
4. Open a different model
5. Also, what is happening is I close workbench.  Then reopen at a later time and it gives same error above with MySQL Workbench has stopped working.

MySQL Workbench 6.06
Windows 8
Ampps Version: 2.0  (Build on January 28 2013)

Thank you.

Jeff Sellers
www.jescor.com
[3 Sep 2013 6:45] Espen Tønnessen
Hi, my exact version is:
MySQL Workbench Community (GPL) for Windows version 6.0.6  revision 11184

Configuration Directory: C:\Users\xx\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 6.0 CE

Cairo Version: 1.8.8

OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit

CPU: 4x Intel(R) Core(TM) i7 CPU       M 640  @ 2.80GHz, 7.9 GiB RAM

Active video adapter NVIDIA NVS 5100M

Installed video RAM: 1024 MB

Current video mode: 1920 x 1200 x 4294967296 colors

Used bit depth: 32

Driver version: 9.18.13.783

Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Current user language: Norsk, bokmål (Norge)
[4 Sep 2013 0:40] Miguel Solorzano
Please try version 6.0.7. Thanks.
[4 Sep 2013 1:19] Jeff Sellers
Sorry guys! But I'm sad to report still problem even with version 6.0.7
I just submitted a different bug report for that on bug report: Bug #70234: Model switch from current to a more recent throws exception

Otherwise thank you for an EXCELLENT modeling tool for MySQL.  I simply love it!

Jeff Sellers
[4 Sep 2013 6:45] Espen Tønnessen
It seems to me that new version solved the problem. Thanks :) I have tried opening several models with no problems.
[4 Sep 2013 11:24] Miguel Solorzano
Closed according last comment. Thanks.