Bug #70168 MySQL Community Server 5.6 Installer for windows crash on 64 bits Win 7 Prof
Submitted: 27 Aug 2013 20:08 Modified: 7 Feb 2014 3:10
Reporter: Phuc Ly Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S1 (Critical)
Version:5.6.13.0/5.6.13.1 OS:Microsoft Windows (Win 7 64bit Prof)
Assigned to: Javier Rivera Zavala CPU Architecture:Any
Tags: crash, installer, Windows 7 Prof 64bit
Triage: Needs Triage: D1 (Critical)

[27 Aug 2013 20:08] Phuc Ly
Description:
Unable to install MySQL Community Server 5.6 (both mysql-installer-community-5.6.13.1.msi and mysql-installer-web-community-5.6.13.0.msi).  The install crashes everytime. Crash message:

MySQLInstaller has stopped working

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLInstaller.exe
  Application Version:	1.3.2.0
  Application Timestamp:	51df220c
  Fault Module Name:	clr.dll
  Fault Module Version:	4.0.30319.18052
  Fault Module Timestamp:	5173c114
  Exception Code:	c0000005
  Exception Offset:	000000000000ce64
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	1f42
  Additional Information 2:	1f42bb8cccbaed6ecff668b61349c130
  Additional Information 3:	40f9
  Additional Information 4:	40f9b060a1b79022339abb542ea8eca8

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Machine Information:
Windows 7 Professional, 64 bits, 32GRam

MD5s were verified.

How to repeat:
Download and install.
[27 Aug 2013 23:54] Miguel Solorzano
Thank you for the bug report. The crash happens starting the installer or at some point? in the last case please provide the install process step by step. Thanls.
[28 Aug 2013 12:24] Phuc Ly
I double clicked on the msi 
Click run at the security warning window
The installer extract and when it says "Please wait while the MySQL Installer processes the current operation" another window popup reporting the installer crashed.
[28 Aug 2013 15:23] Miguel Solorzano
Thank you for the feedback.
[5 Sep 2013 17:13] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70250 duplicate of this one.
[21 Sep 2013 23:31] Jamie Laning
Having what sounds like the same issue updating to 5.6.14.0 on HP G70 laptop, 64-bit.  
Running Windows 7 Home Premium.  
Currently have: 
  MySQL Workbench 5.2 CE
  MySQL Server 5.5
  MySQL Connector Net 6.6.4
[21 Sep 2013 23:37] Jamie Laning
Sorry, my erros is happening in a different spot, it appears...

MSI > Run > Yes > Yes
Update Products Window > Click Install Updates link
"Apply Updates" > Click Execute
Connect to the Internet & Fetch product update information > both checked
Click Next
"The following products will be installed or updated"
Click Execute 
mySQL Server 5.5.33 
  Status: Update Success
  Progress bar is about half way

Message...

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception (0x80004005): The specified service does not exist as an installed service

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18052 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
WexInstaller
    Assembly Version: 1.3.3.0
    Win32 Version: 1.3.3.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer/MySQLInstaller.exe
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18044 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18047 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
WexInstaller.Core
    Assembly Version: 1.3.3.0
    Win32 Version: 1.3.3.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer/WexInstaller.Core.DLL
----------------------------------------
System.DirectoryServices
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.DirectoryServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.DirectoryServices.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
StandardPlugins
    Assembly Version: 1.3.3.0
    Win32 Version: 1.3.3.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer/StandardPlugins.DLL
----------------------------------------
System.ServiceProcess
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceProcess/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.ServiceProcess.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 11.0.50709.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
Interop.Shell32
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer/Interop.Shell32.DLL
----------------------------------------
CustomMarshalers
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/CustomMarshalers/v4.0_4.0.0.0__b03f5f7f11d50a3a/CustomMarshalers.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
[23 Sep 2013 17:16] Miguel Solorzano
marked as duplicate of this one. http://bugs.mysql.com/bug.php?id=70386
[3 Oct 2013 11:24] Ben Ritchie
"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld.exe" --install MySQL55
[3 Oct 2013 11:27] Ben Ritchie
Sorry last comment incomplete..

Ok, so problem here is that the installer references a service named "MySQL55" during upgrade, but old version uses "MySQL"

So trick to fix it is to uninstall the MySQL service and install it with the new name so that the upgrader can run against it and update it later.

Uninstall the old service using :

"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld.exe" --remove

Then install the new name  :

"C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld.exe" --install MySQL55

I tried renaming the service (using regedit) and rebooting but that's a nightmare..
[4 Oct 2013 20:47] Jose Gabriel Valencia Ornelas
Posted by developer:
 
Resubmiting info.

Was tested several scenarios to doing the upgrade installing first 5.6.13
against the latest version 5.6.14 of the installer, (using only the
installer, also another scenario where the older server is uninstalled from
control panel instead of using the installer) removing the data folders
manually too, without any problems.

According to the latest updated made on 03/Oct/2013 seems that the older
install was made manually and with custom settings (no using the installer)
the installer in this cases don't know how to deal with those manual
installation because doesn't store any info about how is setup so the
installer can't do the upgrade. this is not a bug, is working as design.

that is for the installer says and error that can't be removed the service
for the server because is not found... in this cases the uninstall should be
done manually too and then install the new server through the installer (not
manually)

It is probably needed to run the SC util in command line to delete the older
service (SC delete <ServiceName>)

Must be used the installer all the time, not use anymore any manually or msi
packages.

Closing and rejecting the bug for now.
[21 Oct 2013 23:46] Paolo Cuadros
I have the same problem, open the Installer but version 5.6.14 and when UAC asks for permision to run WexInstaller.exe it crashes. I have an HP G60 with AMD TurionX2 processor. I deinstalled everything MySQL, the db, services , connectors, workbench, still shows the same error.
[25 Nov 2013 18:36] Jose Gabriel Valencia Ornelas
Posted by developer:
 
will be included in 1.3.5, the fix correct the weay that the existing service is detected
[21 Dec 2013 19:01] Howard Johnson
What I'm seeing is that the following 3 Windows msi installers don't work (I'm running Window 7 Professional x64):

  * mysql-installer-web-community-5.6.15.0.msi (is suppose to download update content) 
  * mysql-installer-community-5.6.15.0.msi (is suppose to contain update content)

  * mysql-installer-community-5.5.35.0 (is suppose to contain update content, but one version back)

The installers run correctly at first and I am able to ok the agreement.  Then they correctly all find what needs to be updated on my system, which varies a bit by specific installer above as follows:

  * my server  (finds for both 5.6.15 installers: web and web-community)
  * workbench  (finds for both all installers: 5.6.15 and 5.5.35)
  * connector  (finds for both all installers: 5.6.15 and 5.5.35)

All three installers fail to find the correct server to install for one reason or another. 

TIP:  I noticed that the 5.6.15 installers report that they are trying to install 5.1.70 instead of 5.5.35 as it is suppose to.  This was true for both the web installer and the non-web installer.

The error message they report when the server is not found is:  "The remote server returned an error: (404) Not Found."  This is sort of odd especially in the cases where the msi installer contains the content and is not suppose to get it from the web.

TIP2: I'm guessing there is an error in what version the installer is trying to install which not only makes the install impossible, but also causes the non-web installer to go to the web and look even when it should not be doing that.

The 2 installers which in addition to being for the server (i.e. the ones that are suppose to install the connector and workbench) work correctly, in that they install the new connector and workbench, (even though they fail to install the server).
[7 Feb 2014 3:10] Philip Olson
Fixed as of MySQL Installer 1.3.5, and here's the changelog entry:

Sometimes the Installer would fail to locate MySQL Server 5.6.15 for
download, and under some circumstances, the Installer would crash.

Thank you for the bug report.
[6 Oct 2014 10:08] Andrew Hargreaves
I still have the same problem. Running for the first time.

Very simple fix.

1. Open MySQL Installer
2. Click "Catalog..." (Bottom right)
3. Click "Execute" to update the catalog
4. Click "Next" and then "Finish"
5. Click "Add" and you should be able to install the server now with no problems.

Maybe there should be a process run on first open which updates the catalog automatically??

Many thanks Andrew