Bug #70144 Can't define the Workbench as a default program to *.MWB files.
Submitted: 25 Aug 2013 23:52 Modified: 29 Aug 2013 1:30
Reporter: Claudson Martins Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.0.6 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: DEFAULT, program, target, windows
Triage: Needs Triage: D3 (Medium)

[25 Aug 2013 23:52] Claudson Martins
Description:
In this new version (6.0.6) I can't set the MySQL Workbench as a default program to open the *.mwb files.

Going to Open with... > Select the default program > MySQLWorkbench.exe the program don't appear on the list making impossible to set it.

How to repeat:
I tried many times and in differents ways, including using the windows control panel.
[26 Aug 2013 11:09] Peter Laursen
I have both WB 5.2.47 and 6.0.6 installed. After rightclicking a .mwb file .. open with .. navigate to the WB 6.0 executable in Windows Explorer and check 'always open this file type with this program', .mwb files are still opened with the 5.2 version.

Both are installed with 'standalone' .msi installers (not the 'integrated' "MySQL Installer") on my system.
[26 Aug 2013 13:03] Miguel Solorzano
Thank you for the bug report.
[27 Aug 2013 13:45] Alfredo Kojima
How did you install Workbench?
[27 Aug 2013 16:31] Claudson Martins
I used the mysql-workbench-community-6.0.6-win32.msi installer. In this page: http://dev.mysql.com/downloads/tools/workbench/
[28 Aug 2013 8:30] Mike Lischke
Posted by developer:
 
This is neither a bug in MySQL Workbench nor in the installer, but quirky behavior of Windows. http://superuser.com/questions/91655/open-with-dialog-ignores-my-selection has some good answers what the actual reason is.
[28 Aug 2013 8:33] Mike Lischke
If are familiar with the Windows registry the quickest solution is probably to manually remove the key HKEY_CLASSES_ROOT\Applications\MySQLWorkbench.exe. After that the "Open With" dialog works again (via the Browse button) and recreates this key if you select a new executable.
[29 Aug 2013 1:30] Claudson Martins
Problem solved!

Just open the regedit > go to HKEY_CLASSES_ROOT\Applications\MySQLWorkbench.exe and remove it. Now the selection works normally.

Ty guys!