Bug #70136 Switchable null indicators in results window
Submitted: 23 Aug 2013 12:28 Modified: 31 Jan 2018 15:48
Reporter: Steven Morris Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S4 (Feature request)
Version: OS:Any
Assigned to: CPU Architecture:Any

[23 Aug 2013 12:28] Steven Morris
Description:
NULL values display a gray-background box saying "NULL" in the upper left corner of the cell.

How to repeat:
Execute any SELECT query that returns a null.

Suggested fix:
Make this switchable so the cell can be blank when a null is returned.
[13 Sep 2013 12:36] Johannes Taxacher
Hello Steven, 
is that request just for aesthetical reasons or would that serve a different purpose (it's just a graphical indicator that the returned value is in fact not just an empty value but NUL instead)?

BR
Johannes
[13 Sep 2013 19:20] Steven Morris
I teach intro SQL programming at a university.  I prepare class materials for the students showing them what the results of their queries should look like.  There is always a small number of students who become confused on whether a cell should contain NULL (no value) or "NULL" (the actual word "NULL") because of the null indicator.  It would be helpful if I could suppress the graphic.

Thanks!
[9 Jan 2014 1:07] Alfredo Kojima
How would you tell whether an empty cell is NULL or just the empty string ('') ?
[14 Jan 2014 21:42] Steven Morris
You couldn't visually distinguish between NULL and empty string if you toggle off the graphic.  Personally, I've only cared about the difference in code, which would not be affected.  If this is added as a feature -- to make it a toggle -- then people that need to visually distinguish between the two could leave it toggled on.
[31 Jan 2018 15:48] Miguel Solorzano
How explained this is by design which shows real NULL values.