Bug #70097 "Duplicate" button in Manage Server Connections does not work
Submitted: 20 Aug 2013 16:28 Modified: 26 Sep 2013 21:35
Reporter: Paul Blazek Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version: OS:Windows (WIn7 Pro)
Assigned to: CPU Architecture:Any

[20 Aug 2013 16:28] Paul Blazek
The "Duplicate" button in Manage Server Connections does nothing when clicked.

How to repeat:
From the home screen in MySQL Workbench:
1. Click Database->Manage Connections...
2. Select an existing connection
3. Click Duplicate

Suggested fix:
As I understand it, the button should create a new connection with a name like "Copy of XXXXXX" and leave it open for editing.
[20 Aug 2013 17:08] MySQL Verification Team
I couldn't repeat. When clicking duplicate it created 1 connection adding the number 1..2...3 etc. Please check. Thanks.
[21 Aug 2013 21:14] Paul Blazek
It so happens that the connection I wanted to duplicate is "DB1".  When I tried other connections that don't end in "1", it works.  When I tried to duplicate "DBTEST1", it also worked.  I created other short connections ending in 1, such as "AC1".   I was able to duplicate them.  I tried moving "DB1" out of the first position in the list, and couldn't duplicate it.  It seems to fail only when the connection is named "DB1".  Am I hitting an internal variable conflict?
[22 Aug 2013 9:48] MySQL Verification Team
Hello Paul,

Thank you for the bug report.
Verified as described.

I observed that *any* connection strings(DB1, Con1 etc or even DBtest) are not duplicated where as numeric connections are duplicated such as 123 becomes 123X <-- this is incremented for subsequent attempts..

In 5.2.47 - any connection when duplicated makes "New connection X".. so it is not affected.

[26 Sep 2013 21:35] Philip Olson
Fixed as of MySQL Workbench 6.0.7, and here's the changelog entry:

Under certain conditions, the "Database", "Manage Connections",
"Duplicate" action would fail to function. Such as, if a connection with
"No Remote Admin" was enabled.

Thank you for the bug report.