Bug #69975 Misleading error message telling incorrectly of impending server shutdown
Submitted: 9 Aug 2013 16:03 Modified: 9 Aug 2013 16:05
Reporter: Simon Mudd (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.5.23-log OS:Linux (CentOS 6.3 x86_64)
Assigned to: CPU Architecture:Any

[9 Aug 2013 16:03] Simon Mudd
Description:
A real log file (ip/names changed for obvious reasons) but the timestamps are correct shows:

130809  6:19:35 [Warning] IP address '10.xxx.xx.xx' could not be resolved: Name or service not known
130809  9:08:50 [Note] Hostname 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' does not resolve to '10.xxx.xxx.xxx'.
130809  9:08:50 [Note] Hostname 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' has the following IP addresses:
130809  9:08:50 [Note]  - 10.xxx.xxx.xxx

130809 10:21:29 [Warning] IP address '10.xx.xx.xxx' could not be resolved: Name or service not known
130809 10:30:52 [ERROR] /usr/sbin/mysqld: Sort aborted: Server shutdown in progress
130809 10:36:27 [Warning] IP address '10.xxx.xx.xxx' could not be resolved: Name or service not known
130809 10:47:43 [Warning] IP address '10.xxx.xx.xx' could not be resolved: Name or service not known
130809 11:16:17 [Warning] IP address '10.xxx.xx.xx' could not be resolved: Name or service not known

Notice the 'Server shutdown in progress' message. Given the logging and this entry below it's clearly lying.

mysql> show global status like 'uptime';
+---------------+--------+
| Variable_name | Value  |
+---------------+--------+
| Uptime        | 604496 |
+---------------+--------+
1 row in set (0.00 sec)

An error message like this is rather alarming and should be corrected if it hasn't been already.

How to repeat:
not entirely sure.

Suggested fix:
If the sort is aborted that's fine, say so. Do not generate an error which indicates a problem with the server and the fact it's supposedly shutting down if it hasn't.
[9 Aug 2013 16:05] Shane Bester
Looks like a duplicate of http://bugs.mysql.com/bug.php?id=18256