Bug #69819 Unable to export data with MySQL 5.6.12
Submitted: 23 Jul 2013 9:38 Modified: 23 Jul 2013 11:31
Reporter: Christian Doaré Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.6.12 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[23 Jul 2013 9:38] Christian Doaré
Description:
I just installed MySQL 5.6.12 and I am trying to export data using "Data export" utilities in MySQL Workbench.
I got the following message :

WARNING

mysqldump.exe is version 5.5.16, but the MySQL Server to be dumped has version 5.6.12.

Because the version of mysqldump is older than the server, some features may not be backed up properly.

It is recommended you upgrade your local MySQL client programs, including mysqldump to a version equal to or newer than that of the target server.

The path to the dump tool must then be set in Preferences -> Administrator -> Path to mysqldump Tool:

11:36:24 Dumping modèlepalaiseau (bitrate)

Running: mysqldump.exe --defaults-extra-file="c:\docume~1\wmdl5384\locals~1\temp\tmpc2atxf.cnf"  --user=root --max_allowed_packet=1G --host=localhost --port=3306 --default-character-set=utf8 "modèlepalaiseau" "bitrate"

mysqldump: Couldn't execute 'SET OPTION SQL_QUOTE_SHOW_CREATE=1': You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OPTION SQL_QUOTE_SHOW_CREATE=1' at line 1 (1064)

How to repeat:
Just install MySQL 5.6.12, create a table and add some data in this table.
Try to export data using MySQL Workbench.
[23 Jul 2013 11:31] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=68328 .